Android 5.1 "Network Problem" WiFi msg preventing new bulb connection

Hi I’m newbie, Samsung Galaxy S5, and when I try to connect first bulb I get this experience. [1] the bulb shows up in my phone’s list of WiFi devices [2] but when I use the LIFX Android App to Add New Lightbulb, I get error message “Network Problem - It appears that your phone has Avoid Poor Nwks or Auto Nwk Switch enabled. These settings can prevent connection. Go to settings and Disable these”.[3] when I go to IP settings, I have unchecked every nwk option on the list, tried combinations etc and still no joy.

[] I am on Android 5.5.1 kernel 3.4.0
[] Bulb is LIFX Color 1000_1159db_AJ and shows up as “Open” WiFi device on my phone
[] I have never heard of the IP settings in that error msg and don’t know what they are in Android driver, what they really mean etc.
[] I started a f/w update - no visibility on that
[] I tried switching the lamp on off few times, cooled the bulb for 15 mins and retried.
[] tried my wifes Android phone still no joy.
I have three of these bulbs and keen to get developing on them, especially through my Amazon Echo.
thx,
Dave

Update, i tried unchecking the 2.4/5Ghz automatic wifi band select option (Wifi settings) and Voila! The lightbulb suddenly changed brightness which means it connected. But next step, after going through the menu of provisiong the new bulb with my AP credentials after that Mr bulb dissapeared. Gone, cannot be discovered. So, no joy, not up yet.

What is points to is the app initially pointed me to wrong checbox menu for IP settings, should have pointed to Wifi settings menu. Also looks like somehow during attempt to add bulb to nwk its fw likely stopped it from being discoverable. I will get out a wifi sniffer next.
Dave

Yes they are only 2.4ghz bulbs. The app will allow you to claim the bulb, do that and update the firmware.
To reset the bulb there is a switch on it, flick that switch and turn the power on, the bulb should flash colours then be factory reset.
You should be able to claim the bulb then and once you do that you can control it over the 5ghz network as long as your router supports concurrent 2.4 and 5ghz networks. Alas if your router does not support concurrent frequencies then you have to use 2.4 on the router to use the bulbs.
As you said you had to change your frequency then I suspect your router only has 5ghz enabled or only supports one at a time, thus your phone connects to your network but your bulb can’t, it is trying to connect on 2.4 and is not discoverable any more.

Once the bulb has successfully connected to your wifi network once it is no longer discoverable. If we allowed the bulb to be discoverable again simply because it couldn’t connect to the network it would be vulnerable to takeover via de-authentication attack. To get the bulb to be discoverable again reset the bulb back to factory settings.

The other interesting thing is that you can’t talk to the bulb once it is onboarded. This could be a few things:

  • Your 5GHz and 2.4GHz networks are separate and the AP does not forward broadcasts between them.
  • You have AP Isolation turned on.
  • Your wireless network is too lossy
  • Your wireless network is rejecting packets from the bulb for some reason.

I would love to hear the outcome of your wireless sniffing. I also suggest that you make sure to file a support case. The support team has a lot of experience troubleshooting network setups and might provide some helpful hints.

OK here’s the resolution to one problem and a report of new unexpected things, its still not “ordinary smart-user friendly” but certainly is a compelling product once it works.
Problem solved - cannot connect new LIFX devices
[1] to connect new LIFX to my Arris NGV599 dual band WiFi router (I am using Android 5.1.1 Samsung Galaxy S5 mobile phone) I had to set Android WiFi Settings --> Smart Network Switch --> OFF.
[2] it seems that some new f/w was uploaded - cant tell what transpired during setup.
[3] once new devices are on the network and the mobile App can see them, works.

Account login issue:
Not sure why but my LIFX account login password was declared wrong - and I did not mistype it. So I had to go through password reset. Attempt to get a password didnt work the first 2 times and 3rd time it allowed me to reset to my old/original login password! thats odd/frustrating.

Android app Control bug - not sure how the phone App allows a Theme or Effect to turn off or easily undo, back to simple color setting control. Unable to stop “Spooky” setting easily - had to use the Application Manager to stop it.