Bulbs connect to Wifi but not Apple Home Kit Help?

Hello All,

Does anyone have a solution for me or suggestions, Basically i have two 3rd generation A19 (v2.72) bulbs currently connected to my Wifi and claimed etc and on the latest firmware version.

To get these bulbs connected to my Wifi i had to connect directly to the Wifi network broadcast by the bulb and then enter the relevant details for my home Wifi through the Lifx app on my iphone - all working perfectly, however if i want to use the bulbs in conjunction with Apple HomeKit for siri use its a different ball game.

If i select through the Lifx app “Get Code” for homekit it kicks off the setup process again by resetting the bulb and then reconnecting the bulb to my Wifi but it always, always after many attempts and countless bulb resets fails, it just comes up with “An unexpected error occurred” on my iphone

The exact same thing happens if the select the bulb under the “Setup new device” option under wireless networks on my iphone or on my wifes iphone or on either of the two ipads we have.

So i don’t think its anything to do with my Wifi as i can get them to connect, its this stupid HomeKit bit that never works, on the Airport Setup screen is where i receive the error message above. My 3 other bulbs are all setup fine with HomeKit and work well with Siri, why wont these 2 just play nice :slight_smile:

I basically have the exact same problem as this guy the only diference being i want to use HomeKit so its an issue to me. https://community.lifx.com/t/solved-add-bulb-from-ios-app-3-8-1-homekit/3403

I’ve raised a support ticket but thought i would place this post here too in hopes someone may have already fixed the issue.

Thanks

I have had the exact same issue for months now. Please let me know if you find any solutions.

Btw support didn’t help at all.

1 Like

I was encountering the same EXACT issue with my A19 bulbs, and was almost about to give up, when I finally tried what worked FOR ME…

Follow the lifx app “get code” prompts as you were, letting the bulb change colors, etc, and let the app switch over to apple’s Airport Accessory Setup screen. When you get to this screen, it will have the name of the network you’d like to join (should be same as the one the bulbs were previously connected to) and underneath that, pre-filled in the “Accessory” field is your bulb’s full SN, starting with “LIFX…”

I decided to change this accessory name from the default SN, to a short unique word without spaces. “livingroom” for example.

Boom! This worked for all of my bulbs!!! So frustrating, but in the end so happy that a simple name change in “Accessory” did the trick for me!

Hi to all,

I for resolve the issue, i reset the lamp, and setup again.

For reset:
On/off slowly for 5 times , not from app, but from command of On/off from lamp holder.

When you arrive a 5 times take the lamp ON, and she flash , after 20 second you see the wifi’s lamp.

To here follow the step for first installation.

My model is E27 Mini

I was experiencing this issue. I was able to resolve it by resetting my A19 bulb and setting it up to Homekit before setting it up to the LIFX app. Hope this helps.

I couldn’t’t get my LIFX Mini to connect to my HomeKit app for Siri voice activation so I reset the bulb by turning it off and on 5 times at the power source which removed it automatically from my LIFX app. I then added it first to my my HomeKit app before adding it back into the LIFX app. It added immediately and successfully into the HOME app, fixing the problem. I now have voice activation (Siri) from my HomePod and also can control it on from LIFX app too. Hope this solution helps and works if anyone else who is having problems trying to connect your bulb to both apps, LIFX & HOME (Siri)?

4 Likes

How do you connect it back to LIFX app afterwards? I followed your steps and it worked till the part that I was able to add my 2 bulbs to Home app. When open lifx app and choose add, it won’t give any options except for prob resetting the light again and Turn on its WiFi

I created an account just to say THANK YOU!! I was having this problem with the Z Strip and it was driving me insane until I saw your comment about having to add it to HomeKit, first.

This worked for me. I had reset my A19 many times and was doing the logical thing of adding to the LIFX app first. I wasn’t able to get it on HomeKit until I reset it again and added to HomeKit first! I then proceeded to add to the LIFX app. It is finally all working as expected.

Connecting to HomeKit first worked for me too! Both for a Z Strip and a number of downlights. Thanks so much @Jill

And does it ever work for anyone by connecting to the LIFX app first? It feels like this is something that LIFX needs to be honest about and add to their documentation - or at the very least to their troubleshooting info.