LIFX Developer Zone

Cannot Get Paired With My Network

Hello,
I bought a LIFX BR30 bulb new around a week ago from a reputable local dealer, and cannot for the life of my get it working with my network.
My network is somewhat specific, but based on research, not uncommon at all, and I have seen others have success with similar setups.

I have an Opnsense firewall, using OpenWRT for a dumb access point. Each VLAN has their own virtual interface and access points on OpenWRT, that are tagged over to Opnsense essentially. Opnsense handles DHCP, Firewall, everything basically.
I have a few VLANs setup, and I created a new one dedicated for IoT devices (such as the bulb) which blocks connections to my other VLANs as well as WAN.

Now, I confirmed DHCP works by trying to connect my phone to that VLAN.

I first want to state that it is very frustrating there is no privacy respective way to be able to onboard this device. The app is proprietary and closed source and I saw the LIFX LAN project but it does not seem to have Onboarding features. I know you can use Home Assistant or OpenHAB or Lifx Lan to control it, but not to onboard it. I am planning on setting it up with Home Assistant, I just can’t get it on my network!!

Anyways, I installed the app on a junk device, and connected the device to my IoT VLAN. I then opened the app, it found the bulb, said successful. Then it asked for the access point and credentials and it said good. Then it says completing setup, and it just lingers there. I notice the bulb does fade off on once during the onboarding process like it recognizes my connection with the app. So idky it lingers.

Troubleshooting I have tried is:

  • try app sith another device
  • allowing WAN on that interface
  • try on one of my other VLANs which I know are setup properly because I have many other devices on them, they also have WAN access
  • removing a (white)space from the SSID name
  • Hard reset the bulb (turn off on 5 times, it shows color cycle), tried this a few times actually
  • try moving the lamp right next to the access point, and tried a different lamp for the hell of it
  • try changing access point from N to Legacy, disable WMM (it’s using 20Mhz btw)
  • check DHCP logs on Opnsense, I don’t see it trying to lease anything except for the phone
  • Check associations on OpenWRT, hard to tell but not seeing the bulb unless I missed it
  • Check firewall logs, the junk device pegs port 53 thats about it (note I am using Unbound for DNS on Openwrt, but again that VLAN doesn’t have WAN access so it shouldn’t matter)
  • Disable the setting in LIFX app to use cloud for onboarding

Maybe there’s some setting I’m missing on OpenWRT, that it has trouble with. Or maybe the app is jus broken? Idk but this is frustrating and insane.
The one thing I cannot test is a different access point or firewall, however there should be no issue with them because other nonIoT devices work flawlessly. So it could be a setting, or not.

I still am having trouble with this if anyone could help.