Can't connect new lights to wifi network

White 900 BR30 light, Android operating system, Netgear N900 modem/router.

Purchased a single light as a test bulb before buying additional bulbs. During the setup process using a Galaxy S6 (also tried with iOS), the process stalls when it states “looking for light on wifi.” No error messages or any hint of what went wrong. It just stops and the light never connects. Wifi singal strength is good at light’s location. I’ve set all the router settings recommended by product support:

  • 2.4 GHz
  • Channel 1, 6, or 11
  • Mode: Up to 54 Mbps
  • WPA-PSK [AES]

And no success. Product support is very slow to respond (24+ hours via email to each reply) and very generic in their replies (cut-and-paste instructions). Hoping for better support from the community. Might this be a router compatibility problem?

I just want this to work, but very close to giving up and trying another product. This post is my last hope…

Thanks!

1 Like

Im having the same issue, and very surprised that theres still been no reply to this post.
Ive been in touch with the support email but getting one email so far with a generic question when I’m already quite frustrated with not being able to use my quite expensive bulb.
It might be worth lifx developing a proper user guide explaining compatibility with routers and why things may not work as currently I have no idea why it doesnt connect even though I expected a simple process.

Please can someone help with this issue, otherwise I will need to send it back and buy one from another brand.

Im using a Virgin Media Superhub v2.0, channel 1, 2.4 ghz, WPA. (tried connecting it with an android smartphone and tablet with only wifi connection).

Thanks.

I have same setup and issues only difference channel 11

1 Like

Just to update you all on this. It turns out my router just wasn’t compatible with the bulbs. Even though everyone claimed there is no issue, after firmly requesting that my broadband provider (Virgin) sends me a new router (as it was the only thing left to try), the new router arrived and the bulb connected instantly with no issues.

Therefore it would appear that the bulbs do not work with older Virgin broadband routers and so even though Virgin claim it’s not their fault, it definitely was in my case.

Hope that helps!

I bet the old router had a setting where it blocked the UDP traffic over Wi-Fi that LIFX was broadcasting from the app to the lights. That would be my guess.