LIFX Developer Zone

Can't connect to LifX Original through HTTP API

Hi,

I’m no expert on networking, but I was wondering why I can’t connect to the lightbulb through HTTP API.
I’ve included a “setup” of my Home network. It’s really basic.

From a Modem only to a switch (becasue the Digicorder needs an IP address from the ISP).
From the switch, I connect to a small router and behind the router there’s an IPad and a Cellphone, which makes a wireless connection (both have Internet access, through an 192.168.x.x IP-address.

I’ve created a Authorisation token on my profile and tried this command from the Desktop PC:

" https://api.lifx.com/v1/lights/:selector/toggle ", with “:selector” = “all” or “d073d50009e8”

and the result I’ve got:

{
“results”: [
{
“id”: “d073d50009e8”,
“status”: “offline”,
“label”: “”
}
]
}

The bulb seems to be “offline” and it isn’t physically powered off, so according to the HTTP API section “Reachability” it’s unreachable.

I’m able to control the lightbulb through the LifX App 4 via the IPad, but not when I’m using the HTTP API.

Hello,

I tried with my Original just now and it works. Are you able to go into the light settings for your original and at the bottom click “remove from cloud” and then go back into the light settings and click “connect” on the cloud bubble?

If that doesn’t solve the problem, are you able to make a support case? And then the Support team should be able to help.

Thx for your reply.
I’ve simplified the network setup even further, just for testing purposes.

Here’s how it looks for now:

I’ve tried resetting the router, the bulb and everythingthing I possibly could reset.
Took the bulb of the network and connected to the network again.
I do have to say, since I couldn’t get the bulb connected to the internet, I haven’t been able to do a firmware upgrade so far.
But I’m able to turn the bulb “on” and “off” with the LifX4 App, along with changing it’s color.

I think you’d better hold on, cause you’re in for a ride, on this one :slight_smile:
I’ve included a screenshots of the router setup.
Maybe there’s a setting that I’ve missed.







But I still get this result:

But pinging the bulb, doesn’t seem to be a problem…

Further more (but this might be another thing)…
Since I have and IPad (IOS) and a Android Phone, I’ve noticed that the LifX App 4 on both are somewhat different.
On the IPad for example, I can’t create “Scenes” or “Schedules”.
It just shows “Add Device”, as where on the Android Phone, it shows “Add Device, Scene and Schedule”, when I click on the “+” sign.
I only have one 1 account on LifX, so I think that’s actually my “Main Account”, since only the main account can add bulbs.
So I log in with my Android Phone and/or IPad on that same account.

There doesn’t seem to be anything obvious in your router settings.

The developer forums aren’t a great place for working out how to get the lights onto the WIFI/Cloud in the first place.

Are you able to create a support ticket? And mention this thread. We’ll look at your devices and at the App.

Thanks

Ok thx @delfick, for the info.

I’ll have a look at it there.

1 Like