LIFX Developer Zone

Can't get Advanced Options (optional) to work in IFTTT recipe


#1

I am trying to dim my strip lights from 100% to 1% in an IFTTT recipe using the Advanced Options field. I cannot get it to work. I entered in the field this string,

“brightness”: 0.01

Are there any instructions on how to do this? Is there special formatting of the string in the field for it to be correctly read? I’ve tried everything and cannot get it working. Thanks.


#2

Hi mhildebr,

When inputting options in the advanced options section, you do not need to put quotes around the option names specifically, instead, wrap all of the options you want to pass in as one string. So for your specific case you only need to put in “brightness: 0.01”

Regards,
Carl


#3

Actually, to clarify you don’t need the quotes at all.

So just

brightness: 0.01

#4

OK that worked.

Now, is there a way to transition in that same time period, say 10 minutes, from red to green light. So far, the light changes color immediately.


#5

The transition duration option should already be slowly changing the color as well.