LIFX Developer Zone

Day 14 of "Looking for light on network" and timeout error. How to fix it?


#1

Steps to recreate the issue:

  1. Start Android App for LIFX
  2. Click on + sign and select Connect the light
  3. Choose 2.4GHz wireless connection present in my home router.
  4. Enter correct password.
  5. Attached screenshot from Phone app shows exactly where it is stuck

At the Sending WiFi credentials to light option, I have to personally select the LIFX bulb wireless connection from my phone’s WiFi controls. Once that’s done and the phone is connected to the LIFX bulb, it keeps on “Looking for light on network”/

Finally it ends up with a Time Out Error where it asks me to power cycle the light. I have encountered this about 9 times for the 9 attempts I have done and power cycled the bulb 9 times. Still the same.

I have also tried adding the MAC Address of the bulb in the router. MAC address is the Serial Number itself as far as I know.

I have also tried using different channels in the router. But still the same.

Router Used: TP Link Archer C7

Router Firmware: DDWRT

My home wireless router is using:

Wireless Mode: AP
Wireless Network Mode: 2.4 GHz
Channel: 4
Wireless SSID Broadcast: Enabled

Please let me know how to fix this. I have two bulbs and both have the same issue.


#2

I had exactly the same issues Broom. It turned out that my router was - and I quote the ISP here - “noisy, with a very high SNR”. Since they swapped the router I have not had a single issue, so it appears not all routers are created equal. Before it was swapped though I tried some of the advice on here. I had a spare travel router that could also be used as a dedicated access point so I gave it its own SSID, plugged it in in another room and linked it to my main router. Worked like a charm and didn’t have a single problem with that either - so much so I was more than happy to keep that setup if the new router didn’t fix the issue first (which of course it did). My advice is try the AP approach.


#3

Im have the same issue, using UBNT gear (very $$) - its worked fine for ages, but now all my A19 bulbs have dropped off the WIFI and refuse to be re-added, even after resets.
60%+ packet loss, 300ms+ pings
Other devices are fine
Even LIFX-Z Strips are fine, JUST the A19 bulbs.


#4

Yup, same exactly here, I have 7 LIFX bulbs, 2 of them are the new Generation 3 A19/A60. They have been a pain to connect and setup, and today they decided to just not work at all… both of them.

Also, was never able to update the firmware on both the A19, the other bulbs update fine. Ideas anyone?


#5

Had the same problem here! My fix was that my router security was set to WEP (not supported) and not WPA (or other supported platform ). After switching and rebooting my bulb started working. It was still not a smooth fix as it hung up again while returning back to my network but i manually reconnected to my network and somehow it found the bulb. Hope this helps.


#6

Having the same issue here with my UBNT gear and A19+ and Z Strips (HomeKit).


#7

why? the only way to work without overlapping channels is using hhannels 1,6,11.
these days most devices are optimized to use one of these channels and to roam between them.

maybe changing to channel 1,6 or 11 doesn’t solve your problem but it won’t hurt for sure.

Having your WiFi on channel 4 is doing this:

https://www.metageek.com/training/resources/why-channels-1-6-11.html


#8

I had a similar problem after correctly configuring my router and discovered that it was because I was using VPN software on both my laptop and my Android phone. It interferes with not only connecting new lights with the phone application, but also the Windows 10 app. Strange thing is that the status of the lights is displayed correctly in the Windows 10 app, but it’s impossible to control them without disconnecting from the VPN.
May not be your problem, but I thought I’d post this here in case in can help anyone in a similar situation.
Good luck


#9

Make sure you’re using the network key found inside the router and not the provider password, I made that silly mistake and it took me two days to sort it out.:roll_eyes:


#10

Had the exact same issue and after my 2nd day of attempts I came across a fix. I created a guest network on my router. I saw this in one of the many forums and it worked for me, but was complicated sort of. I’ll go into a bit of detail…

Phone is Samsung S8, router is Netgear Nighthawk D7000v2. Firstly I followed all the suggested fixes such as, disabling the 5Ghz band, switching to channel 1, only having 20Mhz on (unclicking 20/40Mhz coexistence in the router which I’m not sure if that’s the right thing?), mode - up to 54mbps. Disabled mobile data on phone, cleared app cache and data, and forgot all networks. Reset the light with 5 on/off toggles.

This is where things get fuzzy. I can’t remember if I connected to the guest network, main network or light itself before using the app and whether of not I chose to forget and auto reconnect with some networks. But I do know it was this or a variation that worked.
Enable guest network 2.4Ghz, no password security, disable SSID broadcast so no one else can see it and enable “Allow guests to see each other and access my local network” which I’m not sure helped? On my phone, I entered a manual network which was the guest network with no security, then I connected to the light from the network settings, went to app, chose for it to connect to guest, no password needed, and it connected. There were a few issues at first, changed networks a couple of times and somehow it showed up and allowed me to save to cloud.
Then I was able to connect to my normal network and disable the guest network and somehow it still works??

I was so close to taking it back. If I run into any issues in the next few days I’ll update this. Never have I been so frustrated setting up a product that has so many issues regarding setup and lack of information. I’d previously got a knock-off bulb from wish.com for $13. Admittedly, quality was average, but the setup was a similar process to LIFX, but the connection was near instant with next to no problems. Makes me wonder if they’re really trying to improve their product considering I’ve read forums from last year and replies from months back.


#11

I have been struggling to connect my LIFX bulb recently (Android phone on 8.1), I thought I’d share a few things that I learnt after getting it to work:
1 - The app does not like you switching context while it is doing it’s job. No switching between apps, no split screen, no locking/unlocking, etc.
I found myself in two places. The first time I tried, it seemed to work ok, but was stuck on connecting to cloud so I decided to switch to chrome check something, and come back. I was then prompted to connect to the bulb by going to network settings. The bulb had already been connected to and credentials sent, the reason it was asking this was because the app got confused. Don’t bother looking for it, it isn’t broadcasting. Reset the bulb and start over in the app.

2 - If using a sky router, check for something called “Wireless Isolation”. I think this was the next obstacle I had to tackle.
After a few failed attempts, I actually deleted all app data and cache and started the app again. I logged back in and started over. This time I was stuck on this specific error. I tried the on/off 5 times thing, but the light never did a colour transition so I reset and started again. This time, I turned off the Wireless Isolation and it all went smoothly.

Unfortunately, I cannot safely identify whether the wireless isolation was the actual fix, but give it a go. I did quite a few re-attempts to connect, and the above information is just the things I think were relevant distilled in the hopes that someone finds it useful.


#12

Had the same problem, left the page without switching to another application. then went to the router settings and changed wireless isolation to on and waited a bit and then switched to off again. and it started uploading the new firmware to the bulb. Thank you. I hope it will work now…