LIFX Developer Zone

Day 14 of "Looking for light on network" error and timeout. How to fix this?


#1

Steps to recreate the issue:

  1. Start Android App for LIFX
  2. Click on + sign and select Connect the light
  3. Choose 2.4GHz wireless connection present in my home router.
  4. Enter correct password.
  5. Attached screenshot from Phone app shows exactly where it is stuck

At the Sending WiFi credentials to light option, I have to personally select the LIFX bulb wireless connection from my phone’s WiFi controls. Once that’s done and the phone is connected to the LIFX bulb, it keeps on “Looking for light on network”

Finally it ends up with a Time Out Error where it asks me to power cycle the light. I have encountered this about 9 times for the 9 attempts I have done and power cycled the bulb 9 times. Still the same.

I have also tried adding the MAC Address of the bulb in the router. MAC address is the Serial Number itself as far as I know.

I have also tried using different channels in the router. But still the same.

Router Used: TP Link Archer C7

Router Firmware: DDWRT

My home wireless router is using:

Wireless Mode: AP
Wireless Network Mode: 2.4 GHz
Channel: 4
Wireless SSID Broadcast: Enabled

Please let me know how to fix this. I have two bulbs and both have the same issue.