LIFX Developer Zone

Endless loop of being unable to connect

Using the android app with the LHA19E26UC10.

“Looking for light on network” - will look forever and will not find the light after the firmware was updated, connection to light works and sending Wi-Fi credentials to light works… then it times out looking for light on network. Tried both 2.4 and 5 Ghz connections. Tried power cycling the bulb as described - turn on/off five times, see color light show, try again. Same issue. Will not find the light on the network.

Tried connecting directly to the bulb as suggested. Hit the back button and continue. This works for other smart lights and other smart devices but will absolutely not work for me. Bulk will not connect.

Using a Netgear modem router C7000.

First contact support.
Second there are a number of posts about this so some reading will be helpful for you.
Third if you had of checked the instructions you would see that only 2.4ghz is supported. Make sure the channel is not outside of the 1 to 11 range.
Lastly this might be the claiming process. Often if you cancel that and then wait a bit and scroll down the list of bulbs you will see your wifi network name appear with your bulbs, from there you can claim them to your cloud account.

None of the posts were useful. Here is how I got it to work.

None of my Android devices would connect. I had an iPod so I tried using that with the LIFX iOS app. That worked immediately. Now I am able to use the device with my Android devices and even used the Amazon Alexa app to add the LIFX skill and turn on/off the light. The app seems a bit crude but at least it works.

Personally I like my Android devices much more than my iOS but, on occasion, developers seem to pay more attention to the iOS because they believe it is more important. Why, I can’t tell you. But this could be a fluke, just something to note.

1 Like

often the problem with Android is that the OS checks the wifi connection and if there is no data it defaults back to the mobile data connection. This means the app can’t connect to the bulb to configure it.
The app will ask you to manually connect to the wifi but this isn’t always the best as still the OS does not see the internet so diverts back to the mobile data connection rather than the wifi even though it is connected.

This is why I always suggest disabling mobile data when you connect bulbs on Android. As there is no mobile data the connection isn’t diverted and it is much more successful.

1 Like

Hi Hinky,

I struggled for a while trying to find a fix to be able to use my Android application. What I did was add a guest network and disabled the password security. To avoid someone else connecting to it, I selected “Hide SSID”. THe trouble seemed to be the password. I then went into the app and manually typed in the SSID in the Android LIFX app. If you need any more clarification, I’d be happy to help.

You are awesome! Thank you for this. This post instantly fixed an issue I was having connecting the lights. Thanks again!

Support has a new process they can enable on your account that is amazing. Ask for it

Can you explain more what this is? I’m still waiting for support to get back to me over a similar issue (and the above fixes aren’t working for me)

Unfortunately I purchased this A19 , I have the same problem, it will just display the message “looking for light on network” and just times out. Then it asks to manually connect to the bulb, which is listed on my WiFi list, it connects, but still won’t do anything. Still “looking for light on network.” Reseted the bulb turning it on 5 times, etc. Unfortunately again, I just have two Android devices, a Galaxy S6 cell phone and a Galaxy Tab S2 and it does not work on either. On other posts the company blames on everything else, on the Android device, on the router, on the walls, on imaginary metal around the router. They try to do everything possible to blame everything else except their junk light bulb.

I had the same problem but fixed it when i realised i was using my provider password and not my network key, The network key can be found inside the router settings.
I really hope that helps someone as it’s a simple thing that had me totally baffled.

Can’t connect Lifx tiles to any router i bought 2 routers same thing pops up saying it cant connect to lifx

What do you mean by make sure the channel is within the 1 to 11 range?

Could you provide screen shots for this please? I’m really struggling.

Google… do some research on your routers wifi setup.

The 802.b/g network, which is 2.4GHz, only has 11 channels, 1-11. The prior post was misleading since Channels 1-11 are built into the 802.b/g network and there are no channels outside of 1-11 within the United States.

David there are countries outside of the US and they have more channels. The LIFX bulb however only supports channels 1 to 11 not more that is a hardware limitation according to LIFX.

Had the same problems. Read this post and pulled out my old iphone 6. Completed set on it. And low and behold everything works including auto connecting to all my Android phones I was using. Picked up my note 8 everything works it it also. Problems solved. Thanks

The first time I connected the A19 out of the box, I had virtually no issues. But after getting a new ISP and new network hardware, I had the same issue where I was continuously unable to connect my A19 bulb to the network via the app. I would do the 5x power cycle rigamaroll, see the bulb show up in the list, choose my 2.4Ghz network (WPA2 Personal, Channel 6, HT20 channel width, band steering ON, medium transmit power) and then the app’s adoption procedure would timeout after about 3 min. I tried tweaking a lot of settings on my Ubiquity AP AC Pro and checked to ensure that the firmware on my Lifx App (installed on my Pixel 3a XL) and by confirming the firmware on the bulb was up to date, but ultimately, the Lifx A19 bulb finally connected immediately after simply unplugging my AP from my router (the LAN connection, not the POE) and plugging it back in). Strange since I thought I had tried the classic ‘unplug/plug’ before but it didn’t work. Maybe it was a combo of the aforementioned settings and the reset was the final thing it needed. Just thought I would share for anyone else second guessing thier AP settings. Keep trying…you’ll figure it out :wink:

I just ordered two bulbs and one would not connect , it was pretty frustrating. I have a iphone 6s. After reading a bit, my solution was to turn off my iPhones cellular data and it connected right away.

By support do you mean bots that link you to their website? Because that is the only support I have been able to find. There are no humans.