LIFX Developer Zone

Extremely Frustrated with Lifx Lights (Asus RT-5300)


#1

Can we get a resolution for fixing these lights with the Asus RT-AC5300? My lights keep dropping off and it’s been getting worse every day. At this point I’m ready to throw in the towel. I’ve tried all the suggestions for trying to get your lights to work with the Asus router and nothing is working. The only firmware that I can work with that is semi usable is back from 8/9/2016 (3.0.0.4.380.3341), and the only way to get the lights to work is to create manual DHCP reservations. There have been 2 firmware releases since then and they are unusable. It seems your lights get worse connectivity with each firmware release. I didn’t spend $400 on a router and over a thousand dollars on lights on to have them not work correctly. I’ve tried all kinds of different settings including turning off Smart Connect and segregating the 2.4 and 5G networks to no avail.

Very Frustrated…


#2

It’s their app that needs a major fix unfortunately.


#3

I too have had to create manual DHCP reservations. Basically the bulbs reconnect to wifi so often that without manual DHCP reservations they will get a new IP address and cause my automation gear to not respond correctly.

Are you controlling the bulbs just with the app, or are you using other means?


#4

same problem, same router, three color 1000’s that wont onboard


#5

Same problem but with router Asus RT-AC3100. I can see the bulbs on the network but stops when the credentials are transferred.


#6

if you don’t mind my asking: are y’all seeing each of the lights show up as an individual device with its own MAC address that you can add to an ACL?

I’ve had as many as 12 warm white lights connected at once (back when they all worked SEVERAL firmware updates so) but the lights showed up in groups such that only 2 or 3 groups showed up as if 1 light was a master in the group and a few others were slaves so that the master light acted as its own virtual private network and controlled the slaves on its own in each group.

i noticed this when i was trying to lock down my router to only accept mac addresses for items I’ve added to my ACL - bunch of theiving teenagers in the neighborhood are trying to break into my router and we’re pegging it.

anyways, i traced the Mac addresses showing up as connected items on my router when it was only protected by password and even with 12 lights controllable via the droid app, only 3 unnamed devices showed up on the network - and their MACs matched the type/model of bulbs used. 8 are standard warm whites, 4 are warm can/recessed lights, and my only working ones are 1.5 year old color lights (one standard and one can/recessed) beyond the 12 mentioned above.

Thanks,
DudeSerius


#7

Just wanted to comment that the issue is not always a problem with the app. For me my single light will not stay connected to either of my routers, for more than maybe 3/4 hours. When the app can’t connect, if I connect to my router, I can see that the light isn’t listed on the connected devices any more.

Its a real deal breaker to me that you either need a special router or special router settings to keep them connected when literally EVERY other wifi device has no problem staying connected.

If this can’t be fixed very soon, my plans to buy 50+ of these for my new house build is definitely not going to happen.


#8

running firmware 3.0.0.4.384_20379 & disabling “airtime fairness” for the 2.4g band only in the wireless-professional tab fixed the onboarding discovery issue i’ve had for the last two years for the ac5300 router. it also fixed my printer not discovering in windows with the ac5300. please report this issue via the router feedback option.


#10

THANK YOU THANK YOU THANK YOU bboi1_94! This fixed my issue!

I have been troubleshooting this problem for weeks where all my colored LIFX lights would connect but none of the 800 White Only Lights and Z Strips would connect to wifi unless I dropped my router from 2.4 Ghz mode from “AUTO” to “G Only”. After returning routers, and even exchanging from an AC3200 Tri band Router, to a LINKSYS WRTX router to now an ASUS AC3100, with no improvements…I stopped returning routers…

I now have an ASUS AC3100 Router with firmware version 3.0.0.4.384_20379… and the second I disabled AIRTIME FAIRNESS under the “N Only Mode”, all my 800 White Lights re-connected along with the LIFX Z strip. So, it seems this may be an issue across multiple newer style routers and the 800 Lights (In my opinion) where it doesn’t like the slower devices…or “MAYBE” a firmware needs to be release for the WHITE 800 lights so it works with airtime fairness…

I’ll be dropping ASUS a note as well. :slight_smile:


#11

I had the same problems with LIFX bulbs and NanoLeaf Tiles using an ASUS and Netgear router/dhcp. I never figured out what the exact problem was but the issues stopped when I changed my whole network to Ubiquiti Unifi switches, USG and controller. Now my LIFX and other stuff is very stable, no more problems. So it must be a router or dhcp server problem as I didn’t change the firmware of the lights and my problems vanished.

I saw that my lights were still connected to the router, I found that the dhcp gave the lights an IP address but I wasn’t able to control the lights.


#12

How do you guys forward your ports? Maybe if we share screenshots on how we forward the 56700 ports, it could help.

After 3 days of sleepless nights I finally got my lights to be stable by using another router (Verizon gateway router g1100) that I attached to my base router(Altice one) by its internet port that I just use for the lights. Default Gateway for Altice one I left at 192.168.1.1 and on the Verizon router I set that to 192.168.2.1. That way both routers will provide internet and not conflict with each other.

What I did first to test if I was forwarding my ports wrong or not was to do a DMZ on the IP of the 2nd router where all the lights are connected to by its own SSID to have all the ports open. Once I did that the lights were rock solid. Then I switched that off and did the port triggering for inbound/outbound TCP/UDP to the 56700 port. I will share some screenshots later, I think I may have done some overkill, but so far so good. Also just to note I have 9 lights. And I know they always say port 1, 6 and 11 are the best. But I use channel 2 as its the less congested in my area and I forced 2.4ghz performance mode of wireless N only with 80mhz channel bandwidth which I know is also not recommended but works for my setup and my lights turn on a whole lot faster.


#13

Just to say: the reason for the 1, 6 or 11 rule is that any other channel will overlap more.

Using channel 2 is like straddling two lanes of a three lane road - you’re in everyone’s way, and it doesn’t get you there any faster.

https://www.metageek.com/training/resources/why-channels-1-6-11.html


#14

Thanks for the info jymbob. Maybe I’ll switch the channels, as I don’t think that would have been causing the issues I was having. Pretty sure it was just me not forwarding the 56700 ports correctly. Any thoughts on how I’m using 2 routers with different 2.4 ghz SSID’s. I have my base router at channel 6 and the 2nd router where the lights are connected to on channel 2. I assume I should always keep those channels different to not interfere correct? I was thinking I could leave the base at 6 and then maybe change the 2nd router to channel 1.


#15

Using 1 and 6 is a good plan even if you’re using the same SSIDs, assuming they’re not already congested.


#16

Just wanted to comment that lights are still rock solid and I went with channel 1 and 6 with different SSID’s. Glad they finally work as I got real close in returning these lights.