Failure to configure LIFX Light strip on Ubiquiti IOT Network

I have a Ubiquiti Dream Machine Pro setup with 3 6LR APs. I have 3 networks: Private, Guest, and IOT.

The IOT Wifi network is 2.4GHZ only and I don’t see channels greater than 11.

I can easily configure the LED Light strip into the private network but if I try to configure using the IOT network on my iPhone it will blink and then timeout. I do see it in the Unifi admin client page but it does not fully provision in the LIFX app.

I have tried the full 5 power pull resets many times. I have forgotten all the other SSIDs on my phone. I have deleted the device from the Lifx cloud after provisioning on the private network and tried.

I have disabled the other wifi networks in the Unifi gui and just left the IOT network running.

I have tried doing the configure by waiting 10 minutes after power reset scenario.

It always behaves the same and times out.

The Private network works every time.

I really want the IOT network because my Hubitat hub is on that network and cannot see the LIFX strip as a result I can’t use it with all my automations.

I don’t have a problem with any other device in the IOT networks. Examples being Hub hub and bulbs, Bond hub and fans.

Suggestions?

For a couple years at least I had a nightmare with LIFX bulbs dropping off my network (according to the LIFX app) and configuration was a huge pain. I am not certain but I believe once UI finally fixed Multicast DNS, the bulbs started acting normal again. I am on the latest betas of all firmware and applications on my UDMP and I too use 2 U6 LR plus 3 other APs. I pasted below my settings in case activating DNS doesn’t fix your issue… I am not saying my settings are perfect, but they seem to work for my IOT devices. Side note - my IOT network is 2.4GHz only



Lol, they should add LIFX too!


Thanks,

I do see a couple differences which I will try. I noticed you have a Bandwidth profile labeled “IOT Low bandwidth” . How is that configured?

I would ignore that. There is a spot where you can create bandwidth profiles so you can limit how much bandwidth any user/device can hog. Most IOT stuff should be low bandwidth so my thought was that artificially limiting IOT devices to lower bandwidth would have no effect on them, but might help prevent significant damage if something/someone were to break in via the IOT network. I essentially wanted to reduce a hacker’s bandwidth from 1Gbps to whatever low limit I set the IOT stuff to.

Thanks that did the trick and they are now configured in the IOT VLAN. Now I have to figure out why Hubitat is not seeing it.

1 Like

I had Hubitat but never ended up using it. I am now on Home Assistant and love it. In Home Assistant I had to call out the IPs of the bulbs as it would only search in the same subnet, maybe it is the same in Hubitat. I only scanned the page but this may help: