LIFX Developer Zone

Found issue with Asus Router Firmware - AC5300


#1

Hi There,

I found an issue with the latest Asus Router Firmware for the RT-AC5300

ASUS RT-AC5300 Firmware version 3.0.0.4.380.3941

Basically Lifx Color 1000 bulbs do not discover correctly (cant connect to bulb, or discover correctly in lifx app) - even existing bulbs that were previously working fine on previous version of router firmware. Setup of new bulbs does not work on this firmware either.

I downgraded to ASUS RT-AC5300 Firmware version 3.0.0.4.380.3341 and things returned to normal and discover correctly.

Not sure of the specifics of why :slight_smile:


I want to tell the LIFX dev team exactly what I think of their work
#2

I am using the DSL-AC68U with a similar firmware revision and had my lights previously using a reserved DHCP address, I removed the reservations and rebooted the router after this I could no longer discover the bulbs at all using Dan’s python LIFX code on LAN API (worked perfectly before). I gave up at this point, all of the bulbs bar one worked perfectly from the app and via the cloud but could not be discovered. I was ready to throw the faulty one out (powering on and off got it working for an hour) and then I cleared my DHCP leases and restarted the router forcing everything to get a new IP address, after this once again all but one was ok however it was a different bulb but that bulb had exactly the same issue as the last one and the last one was now perfect again.

I then set the bulbs back to reserved but into a range of IP addresses outside of my DHCP scope and then no problem discovering them or controlling them all working well except for logitech POP not discovering 2 of the bulbs where I can discover all using Dan’s Python code.

Long story short, try using reserved IP address for your bulbs in a different ip range than your DHCP scope but still on the same subnet of course, so far worked for me.


#3

Thanks for the feedback people! I’ll make sure this goes to the team that does our hardware and router testing. They’ll reach out if they have any further questions!


#4

I am also using the DSL-AC68U. No network issues at home on any device. Only Lifx color 1000 bulbs disconnecting every 5 minutes or so then reconnecting. Tried numerous configs on the router and still the same problem. Does anybody else have issues with the bulbs disconnecting every 5 minutes or so?


#5

As per my previous entry take them out of DHCP and add the bulbs to a reserved IP. That is what worked for me with this router.


#6

Hi, i have certainly tried that as it is a great idea to be honest… but sadly no difference.


#7

Hi boxhead, what firmware are you running on your DSL-AC68U ?


#8

new Beta one. 9.0.0.4.380_3879


#9

@boxhead you are a legend! that worked a treat.

for future readers:

  1. Upgraded the firmware to 9.0.0.4.380_3879
  2. Assigned manual DHCP address to the LIFX bulbs (outside of the DHCP scope)
  3. Changed my 2.4Ghz to channel 11 (instead of auto) - some people say this worked for them, so i set it and now it works, so i dont think i need to change it.
  4. Rebooted to flush everything

#10

New firmware has been released and so far so good with my bulbs. Also fixes NBN VDSL issues as well so win win.


#11

Unfortunately, I cannot use my Sonos and Philips Hue anymore since a couple of days.

As the problem started with my Sonos I thought that the problem was there, so I phoned them first but after an hour of intens searching withe their helpdesk it was clear that my Asus RT-AC5300 was (is) the problem. Probably it has to do with Firmware version 3.0.0.4.380.3941. Because when I installed the older Firmware version 3.0.0.4.380.3341 the problems with Sonos disappeared (almost), however other wifi-problems remain.

The strange thing is that everything worked fine until 2 days ago while the last firmware update is from September.

But I cannot see any solution unless a new firmware from Asus itself.


#12

Hey everyone - I have had this same issue with the latest fw on the ASUS RT-AC3100. I went through trouble shooting, re-connecting, and everything else on our 7 LIFX bulbs. Highly frustrating. I am not sure where to start contacting support, ASUS or LIFX.

I also had weird things happen with the new FW with my LG MusicFlow speakers.

I finally rolled back the fw on the router to Version 3.0.0.4.380.3341 (released on 2016/05/30). Everything is back to normal!

It would be great if the LIFX team picked up a ASUS router and were able to experience the same problems. Then, maybe then, they could tell the ASUS people what they hosed up in the router FW to make the change… or vice versa.

If I can provide any more detail - please let me know.


#13

same problem with RT-AC5300, all three of my color 1000’s fail to onboard


#14

Recently upgraded my Asus RT-5300 to firmware version 3.0.0.4.380_4180 and I am now experiencing issues with delayed control responses from the bulbs when using the iOS app. I have an Amazon Echo Dot that I’ve setup with LIFX and any/all voice commands work to control the lights, but when using my iOS device, they are always intermittent.

What is causing this issue that so many users have complained about when using ASUS routers?


#15

No one at LIFX has gotten a hold of an RT-AC5300 so you guys can experience how frustratingly broken LIFX lights are with it?


#16

I’d also like to note my LIFX lights won’t upgrade, keep dropping out and take forever to connect on the RT-AC5300, but when i used my previous Nighthawk R8000 the lights connect instantly, and bulb firmware upgrade when through smoothly.


#17

Hey, @boxhead, @autohomenewbie.

Kinda noob here, don’t want to be messing around my router’s definitions without knowing what I’m doing so, to clarify:

In Asus WRT you have the ‘pool’ of IPs (basically from 192.168.1.1 to 192.168.1.240). Then I should add my lights starting, for example, on 192.168.1.250 and so on, is this correct? I also have an AC68U router and am also experiencing some problems.


#18

Nope that won’t work, you only have 250 to 254 as addresses available.
Just use the option to set the bulbs as a reserved IP address if you can. Really the issue is the DHCP on the bulbs themselves, they often ask for a new address, like heaps of times.
Try a reserved IP address and change it from there. Also you only need a scope of 50 addresses or less so modify the scope to 192.168.1.10 to 1.100 then put your bulbs in say 110 on.

.1 is the router, .255 is the broadcast address they are taken already.


#19

Hey, @boxhead, thanks for the tip. My lights are having some trouble keeping the connectivity, and I’m not sure of the exact reason this is happening. Setting them on a reserved IP address outside the DHCP scope does not seem to work for me. I also have the RT-AC68U, and right now I have 30 connected IP clients. I’m running Merlin’s firmware, which is supposed to be a little bit better than the default WRT firmware, and I’ve heard of people with 50+ IP clients on the same AP without problems, so right now I’m starting to think that this is either because of too many clients on my AP or just another random fact that I’m missing.


#20

I had an Asus RT-AC3200. with 35 Bulbs, 3 zStrips, and many other wifi electronics. What I noticed is that no matter how much Asus boasted the router’s radio could not handle ~50+ concurrent wifi devices connected at once. What happened was that random devices would get kicked off. When this happened to a LIFx bulb it was noticable. I noticed it happening to my laptop from time to time.

I came to the conclusion that most home routers aren’t designed to handle this many concurrent devices so I turned off the Wifi radio of my Asus RT-AC3200 and purely used it as a router then purchased a Cisco Aironet 3602E Access point which is a work horse and designed for this. Once I did that my wifi network was probably 1000x better and I haven’t had a problem with a bulb dropping out again.

The only problem I currently have is there appears to be a bug in the z strip that when it is connected to a cisco access point it will reboot when receiving the GetState broadcast which renders them unusable.


[URGENT] LIFX Connection dropping