LIFX Developer Zone

Found issue with Asus Router Firmware - AC5300

#5

As per my previous entry take them out of DHCP and add the bulbs to a reserved IP. That is what worked for me with this router.

#6

Hi, i have certainly tried that as it is a great idea to be honest… but sadly no difference.

#7

Hi boxhead, what firmware are you running on your DSL-AC68U ?

#8

new Beta one. 9.0.0.4.380_3879

#9

@boxhead you are a legend! that worked a treat.

for future readers:

  1. Upgraded the firmware to 9.0.0.4.380_3879
  2. Assigned manual DHCP address to the LIFX bulbs (outside of the DHCP scope)
  3. Changed my 2.4Ghz to channel 11 (instead of auto) - some people say this worked for them, so i set it and now it works, so i dont think i need to change it.
  4. Rebooted to flush everything
1 Like
#10

New firmware has been released and so far so good with my bulbs. Also fixes NBN VDSL issues as well so win win.

#11

Unfortunately, I cannot use my Sonos and Philips Hue anymore since a couple of days.

As the problem started with my Sonos I thought that the problem was there, so I phoned them first but after an hour of intens searching withe their helpdesk it was clear that my Asus RT-AC5300 was (is) the problem. Probably it has to do with Firmware version 3.0.0.4.380.3941. Because when I installed the older Firmware version 3.0.0.4.380.3341 the problems with Sonos disappeared (almost), however other wifi-problems remain.

The strange thing is that everything worked fine until 2 days ago while the last firmware update is from September.

But I cannot see any solution unless a new firmware from Asus itself.

#12

Hey everyone - I have had this same issue with the latest fw on the ASUS RT-AC3100. I went through trouble shooting, re-connecting, and everything else on our 7 LIFX bulbs. Highly frustrating. I am not sure where to start contacting support, ASUS or LIFX.

I also had weird things happen with the new FW with my LG MusicFlow speakers.

I finally rolled back the fw on the router to Version 3.0.0.4.380.3341 (released on 2016/05/30). Everything is back to normal!

It would be great if the LIFX team picked up a ASUS router and were able to experience the same problems. Then, maybe then, they could tell the ASUS people what they hosed up in the router FW to make the change… or vice versa.

If I can provide any more detail - please let me know.

#13

same problem with RT-AC5300, all three of my color 1000’s fail to onboard

#14

Recently upgraded my Asus RT-5300 to firmware version 3.0.0.4.380_4180 and I am now experiencing issues with delayed control responses from the bulbs when using the iOS app. I have an Amazon Echo Dot that I’ve setup with LIFX and any/all voice commands work to control the lights, but when using my iOS device, they are always intermittent.

What is causing this issue that so many users have complained about when using ASUS routers?

#15

No one at LIFX has gotten a hold of an RT-AC5300 so you guys can experience how frustratingly broken LIFX lights are with it?

#16

I’d also like to note my LIFX lights won’t upgrade, keep dropping out and take forever to connect on the RT-AC5300, but when i used my previous Nighthawk R8000 the lights connect instantly, and bulb firmware upgrade when through smoothly.

#17

Hey, @boxhead, @autohomenewbie.

Kinda noob here, don’t want to be messing around my router’s definitions without knowing what I’m doing so, to clarify:

In Asus WRT you have the ‘pool’ of IPs (basically from 192.168.1.1 to 192.168.1.240). Then I should add my lights starting, for example, on 192.168.1.250 and so on, is this correct? I also have an AC68U router and am also experiencing some problems.

#18

Nope that won’t work, you only have 250 to 254 as addresses available.
Just use the option to set the bulbs as a reserved IP address if you can. Really the issue is the DHCP on the bulbs themselves, they often ask for a new address, like heaps of times.
Try a reserved IP address and change it from there. Also you only need a scope of 50 addresses or less so modify the scope to 192.168.1.10 to 1.100 then put your bulbs in say 110 on.

.1 is the router, .255 is the broadcast address they are taken already.

#19

Hey, @boxhead, thanks for the tip. My lights are having some trouble keeping the connectivity, and I’m not sure of the exact reason this is happening. Setting them on a reserved IP address outside the DHCP scope does not seem to work for me. I also have the RT-AC68U, and right now I have 30 connected IP clients. I’m running Merlin’s firmware, which is supposed to be a little bit better than the default WRT firmware, and I’ve heard of people with 50+ IP clients on the same AP without problems, so right now I’m starting to think that this is either because of too many clients on my AP or just another random fact that I’m missing.

#20

I had an Asus RT-AC3200. with 35 Bulbs, 3 zStrips, and many other wifi electronics. What I noticed is that no matter how much Asus boasted the router’s radio could not handle ~50+ concurrent wifi devices connected at once. What happened was that random devices would get kicked off. When this happened to a LIFx bulb it was noticable. I noticed it happening to my laptop from time to time.

I came to the conclusion that most home routers aren’t designed to handle this many concurrent devices so I turned off the Wifi radio of my Asus RT-AC3200 and purely used it as a router then purchased a Cisco Aironet 3602E Access point which is a work horse and designed for this. Once I did that my wifi network was probably 1000x better and I haven’t had a problem with a bulb dropping out again.

The only problem I currently have is there appears to be a bug in the z strip that when it is connected to a cisco access point it will reboot when receiving the GetState broadcast which renders them unusable.

[URGENT] LIFX Connection dropping
#21

I have the same router and load custom Merlin firmware. It stabilized it for a while but the new stable versions have the same issue. I think the 380.63 versions will work. Here is the site to check it out https://asuswrt.lostrealm.ca/download. Which @carlosroldao mentioned.

Honestly pick up a cheap dd-wrt router and turn it into an AP just for the bulbs. That finally solved my issues.

#22

running firmware 3.0.0.4.384_20379 & disabling “airtime fairness” for the 2.4g band only in the wireless-professional tab fixed the onboarding discovery issue i’ve had for the last two years for the ac5300 router. it also fixed my printer not discovering in windows with the ac5300. please report this issue via the router feedback option. @daniel_hall please put this in FAQ’s for others with this router.

1 Like
#23

Thanks bboi. I had just got an ac5300 and couldnt get my bulbs to connect when i ran across your post. I am on firmware version 3.0.0.4.384_21045. anyways, I changed that one setting (disabled airtime fairness) and was able to connect all my bulbs easily. Sincere gratitude

#24

Hi Everyone,

I am having some serious issues with my LIFX bulbs and I have no one left to ask. Here it goes…

I’ve used LIFX bulbs for 11 months with little issue, other than the occasional bulb dropping off the network. When this happened, it seems like it took a half hour of experimenting with different ways to re-connect it. For example, one time after multiple factory resets, i had to wait 20 minutes to appear as a wifi network, switch back to the app and it finally connected…

I’ve used these bulbs with both an old linksys router, and now an Asus RT-AC5300. They ALWAYS get hung up during wifi setup - “An unexpected error occured”.

I contacted LIFX support to fix 8 (EIGHT!) bulbs that dropped off my network and wouldn’t reconnect. They eventually gave up and replaced them under warranty.

Now I’m trying to connect those new bulbs they just replaced - fresh virgin bulbs would surely connect, right? They will absolutely not connect to my RT-AC5300 router! Same wifi error all the time - “unexpected error”.

I’ve tried connecting from my iPad and my iPhone. I updated the firmware on my router. The App is up to date. I’ve tried connecting them manually through the App Setup, and I’ve tried using Apple Home kit. I’ve tried connecting them using both “Set up a new device”, or waiting 20 minutes for the bulb to finally appear as a WiFi network - Nothing.

After reading some of these posts, i even went in and made the following changes to my router:

  • Airtime fairness - disabled
  • Control Channel - set from Auto to 1
  • 5Hz 1 and 5GHz2 radios disabled
  • 2.4 GHz set to 20 MHz bandwidth only

Nothing seems to work and I’m getting incredibly frustrated.

I’m not a networking wizard, but am open to trying anything. Do any of you have any suggestions?

Thanks!