LIFX Developer Zone

Found issue with Asus Router Firmware - AC5300


#21

I have the same router and load custom Merlin firmware. It stabilized it for a while but the new stable versions have the same issue. I think the 380.63 versions will work. Here is the site to check it out https://asuswrt.lostrealm.ca/download. Which @carlosroldao mentioned.

Honestly pick up a cheap dd-wrt router and turn it into an AP just for the bulbs. That finally solved my issues.


#22

running firmware 3.0.0.4.384_20379 & disabling “airtime fairness” for the 2.4g band only in the wireless-professional tab fixed the onboarding discovery issue i’ve had for the last two years for the ac5300 router. it also fixed my printer not discovering in windows with the ac5300. please report this issue via the router feedback option. @daniel_hall please put this in FAQ’s for others with this router.


#23

Thanks bboi. I had just got an ac5300 and couldnt get my bulbs to connect when i ran across your post. I am on firmware version 3.0.0.4.384_21045. anyways, I changed that one setting (disabled airtime fairness) and was able to connect all my bulbs easily. Sincere gratitude


#24

Hi Everyone,

I am having some serious issues with my LIFX bulbs and I have no one left to ask. Here it goes…

I’ve used LIFX bulbs for 11 months with little issue, other than the occasional bulb dropping off the network. When this happened, it seems like it took a half hour of experimenting with different ways to re-connect it. For example, one time after multiple factory resets, i had to wait 20 minutes to appear as a wifi network, switch back to the app and it finally connected…

I’ve used these bulbs with both an old linksys router, and now an Asus RT-AC5300. They ALWAYS get hung up during wifi setup - “An unexpected error occured”.

I contacted LIFX support to fix 8 (EIGHT!) bulbs that dropped off my network and wouldn’t reconnect. They eventually gave up and replaced them under warranty.

Now I’m trying to connect those new bulbs they just replaced - fresh virgin bulbs would surely connect, right? They will absolutely not connect to my RT-AC5300 router! Same wifi error all the time - “unexpected error”.

I’ve tried connecting from my iPad and my iPhone. I updated the firmware on my router. The App is up to date. I’ve tried connecting them manually through the App Setup, and I’ve tried using Apple Home kit. I’ve tried connecting them using both “Set up a new device”, or waiting 20 minutes for the bulb to finally appear as a WiFi network - Nothing.

After reading some of these posts, i even went in and made the following changes to my router:

  • Airtime fairness - disabled
  • Control Channel - set from Auto to 1
  • 5Hz 1 and 5GHz2 radios disabled
  • 2.4 GHz set to 20 MHz bandwidth only

Nothing seems to work and I’m getting incredibly frustrated.

I’m not a networking wizard, but am open to trying anything. Do any of you have any suggestions?

Thanks!