Google Home Integration

I was delighted to see that LIFX has finally integrated with Google Home. I immediately disabled my IFTTT applets and set up integration in the Google Home application. It went smoothly but when I tried to turn on/off a light(s) the Google Assistant responded affirmatively, but nothing happened to the lights. I renamed rooms and moved bulbs around, but nothing seemed to work. The assistant recognized every room and light I have but it seems like the cloud service was not connected to Google.

I unlinked my account and attempted to set it up again. After entering my login credentials, I was prompted to “Authorize” the connection of which I tapped the button. After a second or two silk.lifx.co gave me the following error message:
{"error": {"code": 403, "errors": [{"domain": "usageLimits", "extendedHelp": "https://console.developers.google.com/apis/api/weave/quotas?project=857559900502", "message": "Daily Limit Exceeded. The quota will be reset at midnight Pacific Time (PT). You may monitor your quota usage and adjust limits in the API Console: https://console.developers.google.com/apis/api/weave/quotas?project=857559900502", "reason": "dailyLimitExceeded"}], "message": "Daily Limit Exceeded. The quota will be reset at midnight Pacific Time (PT). You may monitor your quota usage and adjust limits in the API Console: https://console.developers.google.com/apis/api/weave/quotas?project=857559900502"}, "message": "Bad Run. Failed to get a result", "reason": "Forbidden", "status": 403, "url": "https://www.googleapis.com/weave/v1/adapters/accept"}

I cleared my cache and tried to re-authorize from a different device but I received the same message. My Google account is not authorized to check on the API limits in the URL above so this is as far as I could troubleshoot. Has anyone else encountered this problem? What is the solution?

I’ve been waiting for a more thorough Google Home/Assistant integration for months and I’d really love to get this working soon.

Mark

Yeah, not working here either. I wondered if it might be the fact that I’m in the UK, but surely not?

Google Home is now available in the UK so I assume that is probably not the problem.

I just attempted to link my account again and it worked. I was able to link the accounts and now the integration works well. I’m still going to have a couple of IFTTT applets to bridge the gap. I’d like to see the ability to turn on scenes.

Yea, not working for me either and now all of my lights are disconnected and I can’t get them back on the network. I thought it was firmware update but it could have been the Google Home integration too. I previously had them on Samsung Smart Things. Not sure if that conflict messed things up or not…

…But regardless even after resetting the bulbs, they just don’t connect to wifi. I got a message that said it did connect, but then it never showed up in the app.

Something between this Google Home update and the latest firmware completely rendered 13 bulbs and a strip unusable. I’m getting really annoyed with my lights all being bright white.

Hi Tom, That’s really odd as the google home integration shouldn’t have made any change to the local settings of the bulb. You might want to open a support ticket about the fact that they are not connecting.

Unfortunately due to significantly higher demand than forecasted and some architecture limits we have had some issues hitting our integration and per user API limits. We now have a much greater API limit and are making improvements to reduce API consumption.

Conscious that people generally just moan on forums I thought I’d say that something seems to have changed in the last 24 hrs, response now is lightening fast and has been all day.

2 Likes