HTTP API Light Requests no longer working

Hi,

I have had this request running successfully using the pulse effect:

https://api.lifx.com/v1/lights/location:Solace/effects/pulse

{
“power_on”: true,
“color”: "rgb:0,153,204"
“from_color”: “rgb:0,153,204”,
“period”: 6,
“persist”: false,
“cycles”: 1
}

All of a sudden, yesterday it stopped working with the following response.

{“The remote server returned an error: (422) Unprocessable Entity.”}

Any help would be appreciated.

Thanks

I’m having similar issues with the endpoints. Every time I generate a token and I make a request against https://api.lifx.com/v1/lights/… I get 404s. I changed absolutely nothing. It broke out of the blue.

They made some changes to the API, however the below settings works for me in the simulator.

{
“color”: “rgb:0,153,204”,
“from_color”: “rgb:0,153,204”,
“period”: 6,
“cycles”: 1,
“persist”: false,
“power_on”: true
}

LIFX API Completely screwed

Hi @Solace,

Can you try sending Content-Type: application/json along with the request. We are adding code to assume that this is the default and we expect it to be deployed to production shortly. Please always send a Content-Type in the future with all requests.

If that doesn’t fix your issue please let us know.

Hi @whoisjuan,

Are you including the trailing slash? Remove the trailing slash and it should work.

Thanks fr the reply.

I’ve tried this and it is not working.

I now get a response however it just says all three of the LIFX Z strips are ‘offline’.

They aren’t because I can still control them from the iOS app fine.

Please help!

Hi @Solace,

It looks like you aren’t running the newest firmware on your LIFX Z’s, Could you please update them and try again? If you have trouble updating them please contact support@lifx.com.