I am extremely annoyed with LIFX

I’ve had one LIFX bulb for over a year now.

  1. All third party Android apps I’ve tried lose the connection constantly.

  2. IFTTT integration loses connection constantly

  3. Official Windows 10 app loses connection often.

  4. Official android app loses connection often.

  5. What the hell.

2 Likes

@skiboo sorry to hear about your issues. I’m a long time LIFX user (since the early days) and I have 23 lights in my house at this point. I’ve never experienced any of those issues with any of my lights. Maybe you have a defective bulb? Also, are you positive the light is staying connected to your network? If your home router has the option, perhaps it’s worth checking to confirm the bulb is connected whenever that issue happens. Either way, I’m sure LIFX support would be happy to help you find a solution or replace your bulb if it’s defective.

One thing to keep in mind though… any 3rd party software you use wasn’t written by LIFX and isn’t in their control, so they can’t really be held responsible for that stuff not working. But if the official app isn’t working, then it sounds more likely to be a problem with the network or the bulb itself.

If you don’t have a router that gives you detail about connected devices, you could try a network scanner app like Fing (Android - iOS).

Good luck!

Thanks for the input!

I have narrowed it down to a defective bulb or a networking issue.

I’m emailing back and forth with support and I’ve sent them two days worth of router logs but they seemed to have stopped replying.

I just bought a Hue starter kit and had connection problems when using my android phone but controlling with my android tablet and Windows PC (third party app) is no issue at all.

I think with so many people having connection issues with LIFX, that the architecture or whatever is just really delicate, or should I say finicky.

The guy who made LIFXtend app for Windows stopped developing because he thought LIFX was too unreliable.

The developer of Lampshade android app (that controls both LIFX and Hue), has said that there is a bug in the LIFX API that is the cause of the connectivity issues that all third party LIFX apps suffer from.

1 Like

I constantly had issues with my LIFX bulbs. I use my android phone mainly to control them. Issues ranged from dropping off the nextwork, to responding to changes to flashing red during the night. It’s only recently with later updates that I haven’t experienced these issues. Although occasionally some bulbs drop off the network, but not nearly as often as they used to. You are within reason to be annoyed but if you wait it out and work with the LIFX team these issues may be resolved. Or you may continue to experiencing these issues in which case you might want to consider asking for a refund.

I hope you are able to fix the issue. Hopefully someone from support eventually responds. Although I’ve found support to be quite responsive, and understanding to a certain degree, as a company their products feel like they are in some kind of beta trial and therefore by extension the customers aren’t entitled to a working product. If you’d ordered them from a department store for example an instant refund would be offered for someone unhappy with the issues they were experiencing.

Touch wood my LIFX bulbs are working a lot better than they were when I first got them, but it didn’t half annoy me when they didn’t work as expected, especially considering I paid full price with shipping on top.

1 Like

I am quite enraged right now.

I just installed my new replacement Color1000.

It is impossible to connect to. I tried from Android and windows 10. It looks like the bulb reaches the final stages of being connected, but then it poops out.

From Windows 10 I get “onboarding error” and in Android I managed to reach “found bulb on wifi” but it only showed up in the app for a few seconds and then disappeared again.

I am not interested in troubleshooting this any further, I would just like to relay this information to you (any LIFX employee who reads this or a prospective customer) so that LIFX may continue to improve their bulb tech, because it is just NOT ready for public consumption.

It is ridiculous to receive a shiny new replacement, even containing new hardware, and having the new replacement working even less reliably than the old discarded bulb.

1 Like

Were you ever able to fix the issues you were having with your LIFX bulbs?

I highly doubt it. It’s been several years and LIFX has not fixed most of the major issues with their bulbs. The LAN protocol flat out does not work, so I had to VLAN all of my bulbs so the devices controlling them are forced to use the cloud protocol. I’ve proven this over and over again and told them about it, yet the issues are still not fixed. I am guessing that the user who made this complaint is not longer a user, like many people. I would be shocked if the company does not go out of business very soon and would never recommend that anyone buy their products.

I just opened the app yesterday, something I never do because it is a joke, but I was out on the patio away from Alexa and tried it. the app tried to start updating my bulbs, and bricked three of them. Totally unrecoverable.

Hi Rooster,

We are working to resolve the issues you’ve outlined.

The LAN protocol does work, the updates provided in the 1.22 firmware substantially improves LAN connectivity. If your firmware update process failed, they can sometimes go into rescue mode which can be recovered from. If you contact support@lifx.com our support team can help recover those lights and failing that will replace any lights that were unrecoverable after a firmware update.

Sorry but the LAN protocol works perfectly, I never have issues with it.
The latest 1.22 firmware is much better but still problems. Google WIFI support checked my logs and told me the LIFX bulbs are continually asking for new IP addresses like constantly and this is causing the system to crash after a while.
Other than that the latest firmware has been brilliant. I use the LAN and HTTP APIs to control my bulbs with no problem.
As to bricked bulbs, never seen that myself, if the firware upload doesn’t work I just factory reset them and then use the updating tool on my PC which updates the bulbs and all works well.

I am not defending LIFX they have problems for sure but things are improving, they are more in doubt over their lack of new products and even stocking product at the moment. There is no smart light switch and no accessories such as connectors for the Z strips. They need real product managers which they seem to lack right now.

Thanks. I really appreciate it and apologize for my frustration - but spending four hours last night on this and two more today, to no avail, trying to get TO the latest firmware. Still trying and will post my results when I have determined that I can do no more on my own.’

I hope to be a happy customer once again in the next 24 hours :-). They are still the best hardware out there, and I’ve stuck it out this long…

Boxhead, thanks. You must be the only person on this forum who has never had a problem with the LAN protocol. at any rate, your response gives me hope. Now, If I can only get the bulbs to update to the latest firmware I’ll confirm. Thanks!

Rooster there are so many people using LAN API’s without a problem it is not just me, you are understandably frustrated and I have been there before with LIFX so it can feel like everyone is having the same issues but most do not. It is frustrating though, before 1.22 my Z strip would drop off every 24 hours and LAN protocol could not find it, after 1.22 no issues. The firmware update worked perfectly on a factory reset Z strip (no setup done still using the initial temporary wifi setup network)

I use LIFXLAN to control my lights over the LAN api and it works well. Be careful with your WIFI access points, often they are causing the issue because LIFX uses not so great wifi hardware, my old Asus router and new Google Wifi hubs work perfectly.

Am sure you have done this before but do the firmware update before you configure a bulb if you are going to reset them. Use a PC (mac or win or linux I believe) with wifi to detect the bulbs and run the update. This for me removed the hub from the equation and made it much more reliable.

It took me 6.5 hours total to upgrade 14 bulbs. After upgrading all bulbs, my LIFX app still only works when I turn off wifi on my phone. Of course, I have no idea what version each builbs is actually using, because LIFX does not include that info in the app as far as I can tell.

Although many people may be using the LAN protocol without issue, There are just as many for whom it does not work. If I put the phone on the same network segment, same old problems. The LAN protocol definitely does not work for me, and for many - this is a fact. Just because it works for a few, does not mean it is acceptable.

Because LIFX works for “lots of people” means nothing to me. It does not work for just as many if not more. And asking consumers to bend over backwards to change their network configurations, routers, etc is not a solution. It may be a solution for developers on this forum, but it is not a solution for Joe Home User - who is going to drop these bulbs like a hot potato. The solution lies in the LIFX product, which looking at these forums, very clearly does not work for droves of users.

This is the ONLY network product I have ever brought onto my network that has issues - another indicator that the problem with with LIFX, and not my setup. Blaming the end users or their networks is not a viable solution, and LIFX needs to figure out what the problem is and address it - or they will go the way of the dinosaur.

Hi Rooster,

The firmware version of the lights is displayed in the Light settings screen.

The latest firmware version for LIFX Original is 2.1, Color 1000, White 800 and LIFX Z is 1.22, for LIFX and LIFX+ it is 2.9.

It sounds like you’ve contacted support in the past, but it will probably be useful if we can review your network setup again to help resolve these problems. We try to test our lights with as many different routers and network configurations as possible. When we can recreate issues with our lights based on the feedback we receive from our customers we try to get those issues resolved.

1 Like

Doh! You’re right, it was right there all along. My apologies. All bulbs are upgraded to v 1.2.2. I closed the ticket on that one, and will open a new one related to the LAN protocol. Right now, if my phone is on the same network segment, only 30% of the bulbs respond to the app. But as before, when I vlan my phone off or turn of wifi on my phone, then 100% of the bulbs respond.