LIFX Developer Zone

I Just Cannot Connect My Bulb Whatsoever


#1

I have tried to contact Lifx support, but that did not help me whatsoever. My last resort is to see if anyone in the forums can help me. I have 2 Lifx Z LED strips and a Lifx Mini Day & Dusk bulb. I was able to successfully connect the LED strips with no problem. The bulb on the other hand has become a nightmare to set up. I have exhausted and tried every possible way to set up this bulb and it wouldn’t work. I did a hardware reset each time I tried to a new way to connect my bulb. I have tried the normal way and nothing. I tried to connect by scanning through homekit and nothing. I tried through the Lifx App and it still couldn’t connect. I tried using the bulbs hotspot(putting my device on airplane mode to ensure my device was only connected to the bulb) and that set up still didn’t work. I tried opening my network and it did end up successfully connecting my bulb, except when I encrypted my network again the bulb gets kicked. I do a hardware reset and then it can’t seem to find the network again. So there’s some problem with the bulb being able to get through the network security. I am aware that there is a update for the bulb, but when I did the update for it I still needed to hardware reset it to reconnect the bulb and that took off the update. I tried using the desktop updated for the bulb and when I connect to the bulbs hotspot and run the updater it can’t seem to find the bulb though it’s on the bulbs hotspot. I tried doing some configuration with my router but nothing seems to work. I have gig speed internet with RCN and I have an Arris modem router. My 2.4ghz and 5.0ghz wifi signals have two different names. My 2.4ghz signal is set to b/g/n (I’ve tried just g/n and n but those didn’t help). My channel is set to auto between 1-11 and 20mhz. My encryption is the recommended one, WPA2 AES. I don’t have any ports blocked. I’ve tried manually added the MAC address of the bulb, but that didn’t seem to do anything. I really don’t want to keep my network open just to accommodate this one bulb’s inability to connect to my network. I don’t know what else I should do.


#2

You sound like you know what you are doing; but I’ll throw out a few suggestions, from my own LIFX onboarding headaches.

First, I have read in other forum threads, that many LIFX bulbs have problems with passwords that are longer than 16 characters long. If your WPA2 Password/Passphrase is longer, you might want to temporarily test what happens if you reduce it to 16 characters or less.

Segregating your 2.4 GHz and 5 GHz networks should definitely help your setup. I originally had a single mixed-mode network and “assumed” that the LIFX app would try to connect via the 2.4 GHz band. That was a mistake. I now segregate my network and verify that I am connected to the 2.4 GHz. network; prior to adding any new LIFX products.

Last, I found that I had additional connectivity/onboarding issues, as my DHCP pool diminished in size. I do not know about your particular network setup; but if your pool of available addresses is running low, you may wish to try increasing it. In my case, I am attempting (Phase one) to add approximately 150 LIFX devices, to a network that was already populated with a wide range of Home Automation and A/V devices. I ended up using CYDER/22 supernet addressing (Reconfiguring my router to a 255.255.252.0 subnet; which increased my pool of available IP addresses on my LAN to 1022 Devices. I also used a Router Address number; which provides the flexibility of easily migrating to a CYDR network of 21 Masking Bits … subnet mask 255.255.248.0, for an available pool of 2046 Local IP addresses.) Once I made that change, onboarding of additional devices suddenly became far more responsive and errors virtually disappeared. (Note, not all routers; especially the majority of consumer-oriented or Cable Company provided, routers are setup for easy adaptability to a CYDR Supernet. I had a rather advanced multi-wan router; but it would not recognize the ability to utilize .0 or .255 network addresses; which fell within the 4-network structore, created by using only 22 masking bits. I chose to up upgrade to a Ubiquiti Edgerouter, that handled supernet addressing withut any problems. Their routers are not simple, plug-and-play devices, compared to most other routers; but are relatively easy to configure, if you preview the manual, first. (Note, once I’ve performed the majority of my new device onboarding, I plan to use Static IP Reservation of each bulb’s Mac address, to place all of my smart bulbs within the same subnet. I find it to be a more organized means of keeping track of devices, based upon their IP address.)

Not sure if any of this will apply to your specific issues; but hopefully, you’ll find something of use.