LIFX Developer Zone

Is the problem HomeKit, or LIFX

Is it just me or does anyone else have issues with HomeKit and LIFX. My HomePod always throws back “there was a problem with one of your devices” etc… and doesn’t turn on a light and then you ask again one or two more times and it works…
Any ideas how I can fix this, what the problem is? I’m on my 3rd router and the issues are the same… it’s so frustrating…
also, I don’t have any issues with my sensibo or August lock. It’s only LIFX lights …

1 Like

Which router are you using? I’m using Ubiquiti Unifi gear and my LIFX bulbs are fairly rock solid (I have about 40 of them too). There are also some HomeKit stability improvements in the new 3.50-BULB beta firmware for some of the bulbs (in particular, the Minis which have been historically flaky).

Are you using a single, or multiple, SSIDs and/or VLANs?

I have 3 SSIDs: One for my normal devices (laptops, phones, etc) which is dual-band and two more. The IOT and LIFX SSIDs are restricted to 2.4Ghz only. I don’t use VLANs (tried it, but mDNS Reflection is crappy) so they’re all on a single /24 network.

I know this is a mega delayed reply, how did you go resolving this?

Grab Discovery.app for macOS or iOS (http://www.tildesoft.com/) and you’ll be able to see if things are working from the perspective of your HomePod.

Basically your client (iOS/Mac/whatever) needs to be able to discover and connect to your HomeKit Hub (_homekit.tcp. - preference is Apple TV, HomePod, iPad according to the Apple docs) and your HomeKit Hub needs to be able to not just see the mDNS service (_hap._tcp.) but connect to UDP port 56700.

I think there’s a bit of misunderstanding when it comes to bonjour proxying or discovery in general.

Bonjour unto itself won’t provide connectivity to the service that’s being multicast via mDNS (or broadcast if your access point converts multicast to broadcast / you don’t have an active IGMP querier), it just lets the client know what services are available and IP/port they’re available on.

If you’re truly on the same broadcast domain then the only device that could potentially prevent access to your lights is your access point.

E.g., If you’ve cient/VLAN/access point isolation turned on which, unless you’re experienced with the kit you’re using, is likely to break things.

Alternatively, some of your lights might just have patch connectivity.

Your LIFX SSID should have the following characteristics for reliability sake (this gets more complicated as you add wireless extenders or other access points, especially if they’re different brands and pretty much unaware of each other):

  • 20MHz channel width
  • Limit the available channels from 1 to 11 (depending on device, you’ll have 12, 13 and 14 - turn that range off or expect issues).
  • Set your TX power to maximum.
  • Use a wireless survey/stumbling tool to determine the channel that’s in use the least. Do this from the vantage point of where you’ve installed your lights; your client might not hear a noisy neighbour that one of your lights can.

Signal strength is typically expressed in =<0dBm. The closer to 0 you are, the better (0 being no loss of signal, which is purely a reference point).

What you’ll find is probably a neighboring AP on channel 1, 6 or 11 that’s around the -80 to -90dBm mark, or if you’re really lucky, you’ll have clear air in 1, 6 or 11.

If clear, then choose that one. If not, then choose the one with the highest loss and offset it by 1.

I can explain why another time, but basically if you find channel 11 is pretty quiet then choose 10 or even 9. Ditto with 6 , choose 4, 5, 7 or 8 and if channel 1 seems decent use 2 or 3.

2 Likes

I’d be interested if anyone else has worked out what the deal is with this issue.

I have nothing but trouble with HomeKit / LIFX control but ONLY when using the HomePod. I can ask Siri to control the lights from my Apple Watch, iPhone or iPad without issue. It’s only the HomePod that fails.

They are all on the same network using the same router.

Suggestions? Comments?

Cheers

It’s the HomePod. It used to be rock solid in iOS12. It’s getting a lot better with the latest iOS 13.3 update for HomePod but still not great.

I’ve had this same issue since I bought my HomePod in 2018 (LifX bulb set was bought few months before that), so that covers all the iOS versions in between, from the one it was shipped with to latest available. The issue is ONLY with LifX bulbs. I have other smart devices, like Eve Energy smart plugs, and they work 100% fine all the time, without any issues.

I’ve already tried just about everything one could imagine (IT system specialist as my profession too). I use Amplifi HD router without any additional mesh points. I’ve tried troubleshooting that too, even joined the beta-releases at one point - but it just turned out that it’s definitely not the router either (or the relatively simple WiFi-setup). Tried for example to disable all the “smart features” etc. from Amplifi config, etc. There’s so many things that point to the fact and confirm that the issue is ONLY between the communication of HomePod + LifX bulbs. If I ask Siri on my Apple Watch (right after I got the error via HomePod), which uses 2.4G WiFi as does LifX bulbs, it works 100%, always without issues. Same goes with my iMac (which utilises 5G WiFi) - and my iPhone. They never fail, every command goes through the LifX bulbs.

I’ve gone through every LifX firmware to the latest over the past year. Nothing has fixed this, or aided the issue even just a bit. This occurs totally randomly - with some outstanding luck you might even go a week without any issues, commanding the LifX bulbs via HomePod. But eventually, and sometimes multiple times per day, HomePod can not reach LifX bulbs or their status.

There’s absolutely 0 problems or issues of any other kind in my network or network setup. And as said, HomePod NEVER fails to command the other HomeKit devices I have.

I wasn’t surprised to find a thread about this, and it doesn’t surprise me that people are immediately going with the “oh but it’s your HomePod what causes this”. No, it’s not the HomePod - definitely at least alone. HomePod works just fine with all other smart devices and HomeKit, but LifX bulbs don’t seem to be playing nice with it, or being fully compatible in a HomePod+HomeKit setup.

I’d definitely return the 4 bulb set if offered a chance for a refund. Before all the tens of hours of troubleshooting over a year, cursing when trying to send a simple task and set the lights just to repeatedly getting this error… I (up to some point) thought that the concept of smart home devices isn’t apparently yet ripe for everyday use. Now I’ve come to realise that it’s just “some smart devices” - like LifX bulbs.

So since 2018: all iOS versions, all router FW-versions (+multiple factory resets and all various configurations), multiple HomePod factory resets (just trying to solve this), all LifX FW-versions with multiple resets to bulbs just trying to solve this - the conflict between HomePod and LifX bulbs (everything else works 100% fine in the network, every other HomeKit device can connect to LifX bulbs from both 2.4G and 5G WiFi), I think it’s pretty sure by now that either it’s the HW/chipset revision on these bulbs that’s terminally bugged/non-compatible, or the firmwares - it’s most likely never going to be fixed.

1 Like

I’m surprised it’s limited to your LIFX bulbs, but it’s absolutely a HomePod thing. If you check the HomePod/Siri subreddit, this is the #1 complaint about HomeKit: HomePods are just dumb.

Edited to say that I can get HomePod to act stupid like this without even needing LIFX. Just map them via Homebridge and HomePod still goes “Some lights didn’t respond”, even when they did.

You also answered your own question by saying that all other iOS devices work just fine with LIFX via HomeKit, which means the LIFX side is not the problem, it’s the HomePod side.

I love my HomePods (and they sound great), but it may be Stockholm Syndrome. :slight_smile:

I just upgraded from Airport Extreme wifi to a mesh system with 3 Eero Pros. I had a lot of issues with LIFX lights when using my HomePod, but when using Siri on my phone the old system worked pretty well. Now with the new Eero system using Siri on my iPhone works perfectly so far, very fast and all the lights turn on. While using the HomePod everything worked even more poorly then when they were connected to the Airport Extreme. I have started doing factory resets with my LIFX lights to see if my HomePod will communicate with the LIFX lights better. Now they do work quite a bit better but far from perfect and not well enough to be satisfied with their performance. I have around 20 LIFX lights they all have the strongest possible wifi connections, according to the Eero app. I am extremely frustrated because I was hoping the new mesh wifi system would fix the issue. Why would using Siri on my phone work perfect, but the HomePod performance is poor?

Hello,

It’s a bit strange that it works with Siri but not the homepod. I imagine what’s happening is your phone has a better connection to your network than the homepod does.

I recommend reaching out to Apple and see if they’re able to provide any assistance.

HomePods use 5Ghz networking almost exclusively. I hardly ever see my HomePods drop to the 2.4Ghz network. It may be something to do with that.

Having said that, I’ve noticed that my HomePods with 13.4 have started to display really flaky behaviour, while Siri on my iPhone, iPad and Mac is all still fine.

@russb, the Discovery app helped me so much - thank you! I have solved my problem by buying a cheap Belkin 802.11a/b/g/n router for the 2.4GHz range while the D-Link modem/router serves the 5GHz range. I just turned off the 2.4GHz range on the D-Link modem/router to avoid conflict.

Background
I initially had a Technicolor modem/router from iiNet and all worked fine: devices, LIFX, Siri, LIFX with Siri. It started to have have wi-fi ‘brown-outs’ where the Internet connection worked for cabled devices but dropped out for wi-fi connections for a few seconds to a few minutes. We gave up and decided to get a new modem. So we bought a D-Link modem router. After setting it up, the LIFX lights would work with Siri for up to 20 seconds and then Siri/HomeKit (the Home app) would show all devices as “No Response”. No matter what settings I changed in the D-Link modem, I could not get the LIFX devices to stay connected to Siri/HomeKit.

Then I came across your post and downloaded the Discovery app. When all connected to the original Technicolor modem/router, I could see in the _hap._tcp section that all LIFX devices were listed. When all connected to the D-Link modem/router, I could see only one LIFX device in the _hap._tcp section. So it became obvious to me that the modem/router was blocking something and I believe that turned out to be mDNS - I’m happy to stand corrected. However I cannot find a setting on the D-Link modem/router that allows the mDNS discovery to flow. So I bought a cheap Belkin router that is connected via cable to the D-Link modem and broadcasts on the 2.4GHz range. I turned the 2.4 GHz range on the D-Link modem off to avoid conflict. When I used the Discovery app, I could see all of the LIFX devices in the _hap._tcp section again and Siri/HomeKit can work with all LIFX devices. Hooray!

If anyone has any idea which setting on the D-Link modem would allow the connections without a separate Belkin router, I would be very interested to hear. The modem does not have an IGMP snoop setting but it does have an IGMP proxy setting, which didn’t seem to make any difference.

Thanks again, @russb!

1 Like

@briholland My pleasure.

  • IGMP Proxy normally refers to forwarding multicast between layer 2 domains (VLANs normally).

  • Home gateways have extremely limited memory typically (normally dedicated specialised memory for a specific purpose). Most devices, when their memory is tapped out, will convert unicast/multicast to broadcast frames and flood them. I have seen instances where some devices just drop frames rather than forward them or drop multicast ingress/egress to wifi.

You’ll struggle, unfortunately, with cheaper devices like DLink.

There isn’t a good cost-effective middle ground between “crap” and “decent” that is turnkey.

Ubiquiti comes close I guess. If you wanted to go that route it’d only be because your current setup is not performant.

Thanks @russb. I must say that your second bullet point was a little beyond my comprehension but I’ll read up and see if I can learn more. Appreciate you providing the info.

I looked up Ubiquiti and found many routers but not a modem/router. Do you know of one?

Do you know of any modem/router in a single device that allows LIFX and Siri to work together? That is, to connect to the Internet at the wall socket and allow the HomeKit Accessory Protocol (HAP) to flow nicely throughout the LAN?

Point taken about D-Link being cheap so I’m happy to hear of more expensive modem/router combinations. I don’t want to put you on the hook for your opinion, although I’ll gladly listen! I’m just wondering if you know of any brands and models that allow LIFX and Siri to communicate freely, as well as connect to the Internet. I just don’t seem to find anything on the outside of a modem/router’s packaging to give me confidence that it will work and, to be honest, I’m not sure what I’m looking for on the packaging. Any tips on how to ensure it would work before spending $400 and being disappointed would be appreciated.

I have Australia’s 100/40 NBN via FTTB (Fibre To The Basement), which is optic fibre to building and copper telephone wire for the last leg within the building using VDSL2.

Many thanks in advance.

@briholland I would recommend using a HomeKit-enabled WiFi mesh to replace your D-Link, i.e. either the eero or Linksys Velop.

By using a HomeKit-enabled router, you know you’ll get the best possible support for HomeKit devices.

I’ve not used either personally, but both seem to be well-regarded by their users. I would probably personally go with the Linksys Velop as eero is owned by Amazon which directly competes in the home automation space, so I’m less confident of eero’s future support for new HomeKit functionality.

However, in your case the single eero device is probably sufficient rather than the significantly more expensive Velop mesh as I’m assuming you’re in an apartment (FTTB) and don’t need the extra mesh units.

Awesome, thanks @Djelibeybi! I didn’t even realise there were HomeKit aware mesh devices. You’re exactly right: I’m in an apartment with FTTB.

Thank you for helping!

1 Like

You’re welcome. Always happy to help a fellow HomeKit enthusiast.