LIFX Developer Zone

Issue with Z Strip and Cisco Equipment


#1

I’m seeing an issue with the Z Strip and Cisco Equipment. Everytime I open the app the Z Strip light flashes and becomes unresponsive. When I look at the packets via Wireshark I see that immediately after the App sends the broadcast packet the Z Strip sends an WLCCP packet to the Access point (which is for WDS) then reboots and tries to grab an IP address again.

WDS is completely disabled in my Cisco Aironet 3602E. I have 35 bulbs and 2 Lifx+ bulbs that are connected with no problems.

If I connect the Z Strip to a little cheap router it works fine. This has currently rendered the Z Strip useless for my network. Is there a reason why it would send this packet to a cisco access point? or is this a bug?

I renamed the extension of the wireshark capture to txt so it will upload:
ZStripFailSequence.pcapng.txt (28.6 KB)


#2

Since this isn’t a support forum, it’d be better to send a request to LIFX Support.


#3

I’ve already contacted support months ago about the issue and sent this updated information days ago. There are many partially support related questions in this community so I decided to post this because if anyone else has the same issue it will at the least give a sense of urgency. I’ve spent over $2000 on my setup and purchased an enterprise access point to get this to work (since there were issues with the Asus router where the bulbs kept disconnecting). I’d like to get my Z Strips working.


[URGENT] LIFX Connection dropping
#4

Update: I enabled 1 radio on my Asus RT-AC3200 and made the Z Strips connect to it. It connects and functions successfully. I’d rather it use my Cisco but this will probably have to work for now until’ the bug is fixed.

What I noticed via Wireshark is that I get the WLCCP packet that originals from the Z Strip when connected to the cisco access point. When connected to Asus it doesn’t send that packet. WLCCP and WDS is disabled in my cisco access point so I’m assuming that the Z Strip is detecting the cisco access point via mac or something and sending that then failing and restarting.

.220 is my cell phone
D0:73:D5:14:D2:04 (LifiLabs_12:d2:04) is the Z Strip
.32 is the Z Strip after it gets the DHCP Offer.


#5

By the way 01:40:96:FF:FF:00 (Aironet_ff:ff:00) does not exist on my network and is not the MAC to any of the access point’s radio interfaces. The Z Strip sends this out only when its connected to the Cisco Aironet 3602E access point.


#6

Hi Elite,

You are working with autonomous AP’s?

have you tried disabling aironet extensions?

kind regards,

Mikkel


#7

Yes this is the CAP3602E with the Autonomous Firmware. I disabled the Aironet Extensions from the beginning. Looking at the wireshark capture. it appears that the Z Strip has some mechanism (possible MAC Prefix) to determine if it is connected to a cisco access point then automatically sends the packets that causes itself to crash shortly after connection.