LAN discovery issue

Hello !

I am facing a weird issue with my Colour 1000 bulbs: I am able to discover them with a Node.js script on my laptop, but not with my Debian server, which is on the same network.

I have two networks (two subnets) at home:

  1. The first one provided by my internet provider’s box, and which is used by the computer and smartphones;
  2. The second one provided by a DrayTek router, and which is used by the various IoT stuff (cameras, Amazon Echos, Xiaomi stuff, and of course the Lifx bulbs).

I connected my laptop on the second network, run the example script from this GitHub: https://github.com/MariusRumpf/node-lifx, and it worked just fine.
I connected my Debian server on the same network (actually, it has access to both at the same time), launched the script, but wasn’t able to communicate with the lights.

I looked with wireshark to figure out whether there were differencies or not between the packets sent by my laptop and those sent by my server, but I couldn’t find a significant difference.
I tried to send the exact same packets as my laptop from my server using netcat, but the bulbs did not respond. It’s like they don’t see the packets, or they just ignore them if they come from my server.

Can anyone point me in the right direction please?

My final goal is to control my bulbs from Home Assistant.

Thank you

Quick update:
I found out on wireshark that my laptop was doing the discovery with the DF flag unset, and my server with the flag set.
I tried to do the discovery again from my server after unsetting the flag, but the bulbs did not respond anyways (while still responding to my laptop).

I updated my Home Assistant installation, and tried again from there, and it appears to work.
I don’t know exactly what caused or solved this, but it works now.