LIFX Developer Zone

Latest firmware not playing nice with Cisco DHCP


#21

hopefully this will work with the .txt extension

dhcp.pcapng.txt (53.4 KB)


#22

Hello, any update? My support case was closed Dec 14th and marked solved and I was redirected to this thread. Yet here I am over a month later and my LIFX bulbs don’t do anything more than the incandescents I bought 10 years ago.

I see a packet cap has been provided. Can the devs comment on whether this is sufficient or if more examples or other info is needed? Could you also please provide an ETA for a fix? Thanks!


#23

+1 on this problem. Bulb unable to successful obtain a DHCP address from a Cisco 3845 series router running c3825-adventerprisek9-mz.150-1.M10.bin.


#24

An updated firmware including a fix is currently undergoing internal testing. I would expect a release sooner rather than later, but unfortunately cannot give you an exact date.


#25

Would this possibly fix the DHCP issue with the Asus RT-AC5300 as well? None of the bulbs onboard with RT-AC5300, but all do with my previous router Nighthawk X6


#26

Firmware version 2.9 for LIFX and LIFX + will become available to all users during the next few hours.

@bboi1_94 according to your other post you own Color 1000 bulbs, this firmware issue affecting DHCP is only available in third generations bulbs (LIFX and LIFX +)


#27

Thanks, florian. A few questions…

  • Do you have a documented process for performing this upgrade?
  • Since the underlying issue is that they cannot obtain an IP address is there some method to do this that doesn’t require a connection to the normal WiFi network? E.g. Will they get the upgrade from my iPhone app during onboarding while my iPhone is connected directly to the bulb?
  • Does this require an iPhone app update first?
  • If yes, what is the iPhone app version required?
  • Is this version 2.9 different from the Release 29 November 2016 version on your firmware updates page on your website?

#28

@benpolzin

Thanks Ben,

Not being able to apply the update on the network is a very good point. I will have to get back onto that with a solution. That will take a bit of extra time though.
At the moment you will be able to upgrade with any recent version of the iOS or Android App but only after having onboarded (until we have solution, you could onboard to any wifi, upgrade and then reset and onboard to your network). iOS and Android App will download the latest firmware update without an app update.
Firmware release 29 targets White 800, Color 1000 and LIFX Z, while this firmware only targets LIFX and LIFX +, so yes they are different.


#29

I dug up an old Airport Express and was able to connect my bulbs to it and upgrade them. After flipping back to my normal wifi network backed by the Cisco IOS DHCP server the bulbs are working fine. Thanks for the fix!


#30

Thanks for letting us know @benpolzin.


#31

We have added beta desktop firmware updaters for LIFX/LIFX+ (Gen3), at the bottom of this page:


#32

@florian Will we get an update for the White 800 and Color 1000 bulbs? I am seeing similar problems and am hoping for a fix. I’m pretty invested in these bulbs at this point.


#33

@bhallier as far as I know we are not aware of any bugs in the DHCP protocol of White 800 and Color 1000.
Can you elaborate about your similar problems?


#34

Circling back here, I upgraded my Cisco Aironet to a Ubiquiti AP and all my DHCP and LIFX bulb issues are no more. The kids can have their dance parties again :slight_smile:


#35

I find that very interesting. Was your cisco doing DHCP before and now something else is? The Ubiquiti AP alone does not provide DHCP. ( and I have not worked with Cisco stuff, in years so don’t know if the Aironet does DHCP).


#36

We are having a similar problem. I think I can see the issue on our side. If the DHCPOFFER message is unicasted (instead of broadcasted) to the LIFX bulb MAC address, it appears to fail. The trace someone else included has the same property. Cisco routers also are rumored to do the same thing.

Is there a fix?


#37

In my situation, it was a Windows DHCP server and then a pfSense server. In both cases the lights were unresponsive or intermittent with the Cisco Aironet AP. I changed every setting I could find on the Aironet, wrecking havoc in the process, and nothing I tried would fix the lights. Switching to Ubiquiti solved the issue for me. The lights were working for me correctly with the Aironet before an update to LIFX (it was over a year ago). Not sure what changed, but they work again with the Ubiquiti AP and I got an upgrade to AC in the process :slight_smile:.


#38

The Color 1000 fail to respond to an offered IP address from my MikroTik Router. I can watch the router logs and see when the Color 1000 hits the network. I can see it being offered an IP address…then nothing after that. The new Color 1100 bulbs that LIFX sent me work fine. I can confirm that there is indeed a similar DHCP bug in the Color 1000.

I used the computer based Firmware updater and have the latest firmware on these bulbs. Please fix them.