LIFX Developer Zone

LIFX + Bulbs not seen on local LAN


#1

Is anyone experiencing a similar problem with the new LIFX Plus bulbs not being “seen” by any 3rd Party apps? I just recently installed 6 new LIFX+ Color 1000 bulbs and only my original LIFX (non plus) are showing in my router’s DHCP list (and visible to 3rd party apps), I was able to discover and join the new lights to my network normally, but they are controllable with the LIFX (IOS) app only.

My issue is the new LIFX Plus bulbs are not being seen at all by any of apps that I use regularly. I searched through the community forums here and didn’t notice anyone else reporting this issue?.

Thanks


#2

Actually there are a lot of discussions about it. This is becoming the bane of LIFX I am sure, there are a number of problems with the bulbs being discovered on all bulbs.
For me my gen 1 bulbs using logitech POP 2 of the bulbs can’t be discovered.
It appears the bulbs are not broadcasting after a while so appear offline etc.


#3

Thanks for your reply. My issue seems not so much a glitch with joining the new bulbs or keeping them “online”, but rather I regularly use 3rd Party apps like Lightbow and LightDJ Pro to create varying effects. My problem is specifically that these 3rd Party apps do not “see” the new LIFX+ bulbs at all. I believe these new bulbs are referred to as Gen 3. The earlier Gen bulb I have is visible in these apps just fine, but for reasons unknown (at the moment) - the new bulbs don’t appear.

That being said - the default LIFX app sees and can control all of the bulbs. In speaking with LIFX so far, I am being told it is possible the SDK used for developing thse apps I mentioned may be outdated, but I have not been able to confirm that as of yet. I will say LIFX has been very helpful to me in hearing my issue. I’m hopeful someone here has an answer and a potential fix.


#4

Exactly what we are all seeing. The bulbs are working well with cloud control but LAN based apps are having issues not seeing bulbs etc.
“See Inconsistency wireless connection with lifx” as an example

For me I have also seen where a LAN based search for bulbs on my network using multiple tools fails to find any bulbs but the app controls them just fine. Try later and they are suddenly working again.
I have found my bulbs a lot more stable after I moved them to a reserved IP addresses outside of my DHCP scope.


#5

We have identified a bug in the firmware of the new LIFX and LIFX+ lights where instead of sending broadcast responses (where the source field in the request is set to a non-zero value) to port 56700 it is sent to an incorrect port. We are currently working on a firmware fix for this issue and I’ll update this thread with any information I get from our firmware team.

There are two workaround that you can use right now to fix this.

  1. When sending a LIFX packet set the source field to a non zero value, the response packet from the bulb will then be sent directly back as a unicast packet to the source port in the request packet. As this method avoids a broadcast response from the bulb you should actually receive the packet in a more reliable manner over. This is the preferred way to send packets to bulbs.

  2. In addition to listening on port 56700 for responses, also listen on port 31965 (the incorrect port in the broadcast responses). We don’t recommend this approach, however it could be used as a quick fix while you implement the above.


LIFX Generation 3 Products
#6

Hey Daniel. Really appreciate LIFX’s quick response and the engineering team taking a closer look at this. From an end user perspective, it sounds like the firmware update (when available) should fix the problem.

In the meantime - the developers of the apps I use would need to implement the suggested workarounds to their app for the GEN3 bulbs to become “visible”. Correct?

Thanks again for the support and Happy Thanksgiving All!


#7

First off, an update: The firmware team have isolated the issue and produce a fixed version of the firmware. We are currently putting it through QA to ensure it doesn’t break any other functionality. Once this is completed we will begin a Beta test, and I’ll post instructions here on how you can participate in that when its ready.

Third party developers can either implement one of the workarounds above (#1 is preferred, but #2 is a quicker fix for most applications) or wait for the firmware fix to be released.


#8

Hi Daniel,

I am not a developer but a consumer…I have four brand new Gen3 BR30’s and another four on the way. I would be happy to beta test this new firmware update if you need a consumer like me.

If you don’t…no worries.

James


#9

Hi

Same as jamelser above. I bought the new br30 lights and I was intending to use them as part of a outdoor Christmas display My other bulbs work. Kids are going to be a little dissapoonted. Wife is already yelling at me with the " you and your projects "
So I will gladly test out the beta firmware.


#10

I’m also one who likes to jazz up the outside with different lighting colors for the seasons or mood lighting, parties or whatever. And I certainly understand the “you and your projects” comment - my wife says the exact same thing!

Looking forward to the firmware update as well. Keep in mind friends, my reason for starting this thread and asking for LIFX help is ONLY related to the trouble I was having with 3rd party apps that I use regularly. For me - the new bulbs would not show up on those 3rd party applications I mentioned earlier.

I do want to clarify that my experience “functionality-wise” using the new BR30 LIFX+ bulbs along with the LIFX APP - the bulbs ARE programmable and work just as they should. If you have a lot of new bulbs - I highly recommend on-boarding them one at a time. In other words - don’t turn them all on at once and try to join them to your network at the same time. I did that and it just took patience (and a little head scratching) to reset them and join them one by one.

I’m very much able to customize the colors on all my LIFX multi-gen lights whether it be individual bulbs, or in groups, etc. - just as the LIFX app allows you to. (I use the LIFX IOS app and today I just installed the LIFX Windows 10 app to try it out).

Thank you


#11

Completely understood. I was relying on using Scintillator (3rd party app) to control the outside lights / landscape lights to certain colors , rythms and sounds. The bulbs work fine within the lifx app Any idea on timeframe for a firmware update?


#12

What about first gen bulbs seeing a similar if not same issue ?


#13

Our firmware developers considered this change simple enough (astute observers will note that 31965 is 56700 in reverse endianness) and important enough that we have bypassed the beta stage and are rolling the firmware fix out to all users right now.

If the LIFX application is not prompting you to update your firmware, try force closing it and then reopen it.

Haven’t we all heard that one before? Hopefully we got the fix out fast enough to save you from too much marital discomfort.

I haven’t found any instances of the same issue (port endianess swap) on any of the older bulbs at this time.


#14

sounds like it isn’t this issue but I do know I am often unable to get the bulbs to respond to a discovery using your Python script or any other. I have 2 bulbs that can’t be seen by POP at all.
It is a pain as I have 7 bulbs which isn’t a lot compared to some but to me it is annoying.

Good thing is a majority of the time all works well, mostly.


#15

Have you got a support ticket open for this that I can look into tomorrow?


#16

I will say at this very moment…it WORKS!! I had to shut power off to the lights, close the app. After I opened it again, the lights recognized the firmware update. It took less than 60 seconds and all my lights are now seen on the third party apps I am used to using. Let me do more testing as this was an immediate reaction/post. I will get back to you soon. Thank you - so far looks promising! Light DJ and LightBow - hold off on any changes because so far I am good with the firmware update. P.S. CATAUTO - I use SCINTILLATOR as well…give me a day or so through the holiday and I will report back. Thank you LIFX Team!


#17

No I don’t as the LAN protocol discovery isn’t important to me right now and the POP issue I thought I should take up with Logitech but I can create a ticket if you think it is needed.


#18

Just FYI

There was no firmware update option for my Ipad. I was able to update through Android phone.

Had lots of bizarre connectivity issues, but end result is all my lights (four Gen 3 and two Gen 2 lights) can be seen by my third party app. I am using Onsong as the third party app.

Thanks


#19

Hi LIFX Friends…was able to give all the lights a good run through over the holiday. The firmware update (for me) solved the immediate problem without a doubt. I use primarily the 3 apps mentioned here…Light DJ Pro, Scintillator and LightBow for creating the special effects/scenes I enjoy. The fact that LIFX stepped in and worked this so quickly impressed me about this company.

A little background…I started out using Phillips HUE bulbs about 2 years ago. I run 15 BR30’s ALL OUTSIDE in cans. Yes, I know that was not recommended, but I chose to assume the risks if they blew out. I live in Wisconsin, so my bulbs have seen heavy temperature swings from -20 F to +95. The one thing that first I was not impressed with (HUE) was the lack of good Green and Blue colors - I know this was by design after research…so I was okay with it since I’m already invested quite a bit. One other thing is I’m also huge into DJ’ing and if anything - doing a lot of effects with lighting. Rapid changes were very important to me. HUE originally had what they called “Point Symbols” in their API. It was undocumented, but still sorta used by programmers who understood how to create rapid change effects. Not everyone is a fan of that, but for me - that was a big deal. So - when Hue dropped that capability from their API, it kind of was the second strike I had against them. By this time, I had already purchased 1 LIFX bulb to test out earlier this year.

The color of the 1 LIFX bulb I was testing and comparing was so much better (to me) and I had spoken with a few developers about my own way of using the lights. This Summer - I also invested in ARLO cameras. When LIFX announced that the GEN3 would do IR, combined with what I felt was better color and the bulbs reaction much quicker - I opted to re-invest in LIFX bulbs over HUE. So - now you arrive at my problem at the beginning of this thread. When I got the new LIFX GEN3’s out of the box - the apps I use didn’t see them - this was a bit disheartening.

I don’t think Phillips would have ever helped out this quickly with an issue as LIFX did - though I could be wrong. I will say it seemed Phillips certainly cared less about me voicing concerns when they dropped “point symbols”. To me - in taking something away from a consumer they bought you for, that causes me concern. I just found that to be a deal breaker.

Today - I have 9 of the 15 HUE bulbs replaced with LIFX and will soon replace the remaining 6. I’ll admit for me anyway - it is not cheap to do a complete replacement all at once. Most apps I use can control both brands of bulbs at the same time, so other than the color differences, it hasn’t been that bad. I’m just replacing them as I go.

I have to thank LIFX for engaging on this issue (on twitter as well) and getting engineers to review this so fast! Very good business to consumer interaction…especially as GEN3 is the new flagship product… I’m hopeful that this thread has solved some headaches both that consumers and developers may have run into. I still have a few connectivity quirks, but I think those may be app related and will try to isolate/reproduce and take up with the app dev’s.

Thanks again!


#20

Hi Daniel,
I have 9 bulbs that I was never able to get to work with my Android app or multiple routers and was subsequently issued a refund. I still have them installed in the lights, using them as regular bulbs, but I’m interested in testing to see if the new firmware makes any difference. Can you direct me to the page where I can download the latest “bulb updater” so that I can test these again? I’ll let you know if I find any success.
Also, is there a place where I can determine the exact version of the Android app I have installed? I tested the Beta, but I’m not sure if it’s been updating to the latest Beta or just the regular releases.
Thanks.