LIFX + Bulbs not seen on local LAN

What’s the version number of the firmware with this fix? My bulbs recently updated, and are now running 1.20. I can’t get any response from the GetService packets, using software that used to work. I’ve tried both zero and non-zero source fields, and I’ve tried listening for responses on port 57600 and 31965. So I’m not sure if I’m currently running the known bad firmware, or if I’m now on the version that is supposed to be fixed.

Wireshark shows my Android phone and the bulbs communicating OK, but my previously working code no longer gets a response to a GetServce.

Hi Chris,

the issue in this thread is affecting 3rd generation bulbs (LIFX, LIFX + specifically), the latest firmware for generation 3 is 2.7.
If your bulbs are running 1.20 they will be generation 2 bulbs (White 800, Color 1000 etc). 1.20 is the latest firmware version for generation 2.
I will answer in your separate thread as to what might be wrong with your packet (if I find something that is).