LIFX bulbs on separate vlan

Hi,

I’ve purchased a couple LIFX bulbs which I’ve setup on a separate vlan, however, I’ve noticed that the bulbs are not discoverable through the app likely because broadcast messages are not being forwarded. Is there anyway around this or is it possible to add the bulbs manually to the app by specifying their IPs?

Thanks,
Mal

Hi Malcom -

As you saw in my previous post, you need to use a udp broadcast repeater/reflector that lets the port 56700 broadcast transverse the two subnets.

Let just link to that post to help people find it.

1 Like

Malcom,

I have all my bulbs on one VLAN and a home automation system on another. I do what’s called a directed broadcast on my core switch (Cisco 3560x) so that any network broadcasts received from the bulbs are directed to a single IP address on the other VLAN. This keeps the broadcasts from the bulbs from appearing to all machines on the seperate VLAN and works very well. I do the same thing in reverse so that my home automation system can do queries for the bulbs by sending broadcasts to the network and these are directed to the bulbs on the other VLAN. In this manner, my home automation system (HS3) can send/receive commands from the bulbs directly on the other VLAN.

As an example, VLAN 10 is where the bulbs live and VLAN 20 is where the home automation system lives. 192.168.20.100 is my dhcp server and 192.168.20.200 is my home automation server. I have everything set using DCHP reservations so my bulbs don’t change IPs on me. They are assigned 192.168.10.101-104.

ip forward-protocol udp 56700

access-list 101 permit udp host 192.168.20.200 any eq 56700
access-list 102 permit udp host 192.168.10.101 any eq 56700
access-list 102 permit udp host 192.168.10.102 any eq 56700
access-list 102 permit udp host 192.168.10.103 any eq 56700
access-list 102 permit udp host 192.168.10.104 any eq 56700

interface Vlan10
ip address 192.168.10.1 255.255.255.0
ip helper-address 192.168.20.100
ip helper-address 192.168.20.255
ip directed-broadcast 101

interface Vlan20
ip address 192.168.20.1 255.255.255.0
ip helper-address 192.168.10.255
ip directed-broadcast 102

Hope this helps.

1 Like