LIFX releases iOS (3.8.1) to beta with support for HomeKit

LIFX has released a new version of the iOS app (3.8.1) into beta today which includes support for Apple HomeKit on the LIFX and LIFX+ lights.

If you would like to join the beta, enter your details into this form and we’ll get you added to our TestFlight beta list : https://docs.google.com/forms/d/e/1FAIpQLSfFHU1IKvbgRElwTPKNI7gDJ42Icmj4nI1pTfL44fjgu9Dv-g/viewform

We expect that this version will get a full public release fairly soon.

I downloaded the 3.8.1 beta, updated firmware, but HomeKit can’t see my Lights. Mine are all at least 1-2 years old.
What’s the trick to get HomeKit to see them?
I’m running IOS 11.
Maurice

Hi altmaurice,

The only currently available lights that support HomeKit are the LIFX and LIFX+ lights which were released in Q4 2016. If you have older lights, they don’t have the necessary hardware to support HomeKit unfortunately. If some of your lights are LIFX or LIFX+ models and HomeKit isn’t working properly, please contact support@lifx.com and we can investigate for you.

Thanks for this! Any plans to add the current LIFX Z led strip?

Down load the LIFX app update and it will update the bulb firmware and get HomeKit codes so they will setup manually if the automated process fails…thanks finally Lifx…would have been nicer if you had just said its coming with the ios 11 update…now it works perfectly with HomeKit…no problems at this point in time 4:00 pm EST

The implementation of this is SO bad - I can’t even express how bad. I go through a firmware update of my 35ish bulbs. Then I get to a screen where I have to get a HomeKit code for EACH device … and pair EACH device individually. That may be an apple implementation issue … it makes it a LOT of effort but ok, maybe not LIFX fault.

But the process for getting a code…
It has to reset my bulbs … rejoin to WIFI … and ofc during this process it looses the name - and resets to LIFX XX XXXXX - which means I have to reset up all of my integrations with home assistant.

Its simply not worth my time - another appalling implementation by LIFX. It’s like you don’t test your shit with a larger number of units - otherwise the user experience alarm bells would be going crazy.

/Adrian
A really unhappy LIFX user now… this is probably the last straw.

The new firmware killed all of my bulbs that the app attempted to update. They won’t connect to the Wi-Fi now.

Factory reset one of them, it shows up in the “set up accessory” list in the Wi-Fi section on iOS11, but won’t connect to the Wi-Fi. “An unexpected error ocurred.”

Sigh.

Edit: Ok, managed to coax 3 back to life, though none of them will pair to the network anymore. Two were bricked by the update. ffs

Okay everyone, can we please try and be civil? I’ve barely ever had to pull out the mod tool for these forums, and I really don’t want to have to.

@acantril Unfortunately the HomeKit code retrieval process process does require a reset. We can’t really get around this. That said, Home Assistant should not be identifying bulbs by the bulb label. A serial number is much more stable. I will try to get in touch with them and raise this issue, but as a user your feedback will hold more weight.

@baraqyal What was the issue with the first three? Have you reached out to our support team at support@lifx.com yet?

Not yet, wanted to see if others were having the same issue. So the app went through and updated the bulbs, but all of them failed. It asked me to power cycle them so I did.

None of them rejoined the Wi-Fi. Three of them switched back on to their previous state though. The other two did not.

So I went about resetting all five of them. The three that switched back on when power cycled were able to be reset, but I cannot pair them. There seems to be a new UI in iOS 11 for pairing Wi-Fi accessories?

I was not able to reset the other two.

Edit: Fired off an email to support.

@acantril as @daniel_hall mentioned recovering the HomeKit code does require a light reset but the process should restore the original light name and state once it is complete. If this didn’t happen for you, then we’ll investigate further. We recognize that recovering the HomeKit code for large installs of lights isn’t going to be a fun experience, but work to try and address this within Apple’s rules around how code recovery could work.

@jimbatterson The currently available LIFX Z doesn’t have the necessary hardware to support HomeKit unfortunately.

I thought that I had read (here?) that the LFX Z did?

I updated my Gen 3 bulbs and can now control via HomeKit. The code process, once its obtained, is no different to Elgato or Nanoleaf. One device at a time

I thought the new version of HomeKit did not anymore require special hardware for devices which should be included into the HomeKit-Environment. What’s the reason older lights are not HomeKit enabled?

1 Like

If you have multiple lights, this can be a time consuming process. One thing I learned after attempting to re-connect a couple of bulbs is that there is a length limit to the name of the bulb you are trying to join. If it fails to connect, try using a shorter name.

Okay, I need to chime in with my woeful experiences too. Anyone experiencing this kind of thing? It’s completely doing my head in.

  1. Try and ask Siri to turn lights on or off and it says the light isn’t responding or that some lights aren’t being responsive or it didn’t hear back from them, etc. Wording always different as Siri seems to mix it up to try and stay interesting?

  2. Find a visitor or one of the kids has switched off a light. Definitely hasn’t been done on/off five times for a reset cycle, but still comes up with the different colours and needs to be re-paired from scratch. Has happened to pretty much every light at least twice in the last few days, after going through all the pain mentioned in previous posts. Even my bedroom light. So sick of going through the complete setup process again and again, and it never remembers my light names. See more below.

  3. If you give the light a good name in HomeKit like “light in your bedroom” in a group called “my bedroom”, you can say “Hey Siri, turn on the light in my bedroom”. Siri does so and responds with “the light in your bedroom is on” which has a natural AI style feel. But when you go through the re-pairing process I mentioned in step 2, all the naming is lost again.

  4. Lights randomly grouping, as in morphing together. So what I’m seeing is I have “boy’s bedroom”, “bob’s Bedroom” and “my bedroom” for example. Three different lights. All in one LIFX group called “Bedrooms”, but three different HomeKit rooms. Then I’ll find I have the light in my bedroom in the “bob’s bedroom” room in HomeKit. Then if I move it back to the other room, it still isn’t right. I’ve ended up with two lights in LIFX app linked to the one single HomeKit light, even though they have different serial numbers and pairing codes. WTF? It’s happened like five times already.

Tonight I had my bedroom and bob’s bedroom (not his real name) linked like that. If I remove the pairing it breaks it for both LIFX lights. So I reset with the 5x on/off method, after removing from HomeKit and LiFX app and fixed it. Five seconds later I find it has linked my bedroom to boy’s bedroom instead.

Tomorrow I will remove all three lights from HomeKit and LIFX app, reset them, reboot my phone and start from scratch (yet again!). I’ll document my process and the results. But this is getting crazy. Seriously frustrating.

Has anyone else been experiencing any of these symptoms?

Oh, and I’ll throw on one more issue not related to HomeKit…

  1. Try and dim or turn lights on or off with LIFX app over wifi (which uses UDP) and a lot of the time get no response. Turn wifi off and it uses the cloud method (TCP) and works brilliantly. Have been through LIFX support on this one and they gave me new firmware to try about two weeks ago, which helped for the most part, but new firmware to support HomeKit seems to have made it worse. So may be forked versioning/fixes in the builds that will hopefully merge again?

These things are meant to make our lives easier. I haven’t played with lights for so many hours in my life.

Oh, and 6…

  1. Related to the various issues above, some lights now not coming on at dusk etc because they’ve reset. So come home to a dark house in some areas. The “Hey Siri, I’m home” and “goodnight” features are soooo awesome, but it only works if the lights actually respond.

Okay, worse than I thought. Frustration building.

Re my last post, I went through a very medodical approach last night of removing all three bedroom lights from HomeKit and then from lifx app (on iOS). Then reset the lights with the on/off method. Left them physically switched off and set each one up owls and carefully and all was good. Ended up with 17 of my 19 bulbs all sorted, all names and working perfectly in LIFX app and in HomeKit/Siri.

Went to set up light number 18 for the first time today.

During pairing process (was already in LIFX app) it said to switch to settings and connect my bulb. Now I’ve had a cascading effect.

That new outside light ended up showing in LIFX as being in the family room (it isn’t). Moved the room in LIFX app and it got worse. Then as I checked lights I’d see one in the wrong wrong. Move it and so on and so on. Pretty much ALL my lights have ended up in wrong rooms and removing the pairing just makes another one move.

Only fix from here will be to flatten everything and start from scratch, but I’m not gonna go anywhere near the LIFX app.

HomeKit is fine - it isn’t doing anything wrong or moving lights around - it’s just what the LIFX app thinks is the HomeKit room, and it’s getting it wrong and very confused.

Actually going to remove the LIFX app completely so it can’t screw up HomeKit. Just too scared (and scarred!) to go near it again. It’s getting absolutely ridiculous.

I have screenshots that show it all. I can upload if anyone interested.

Am I the only one experiencing this?