LIFX Z HTTP mixed results - Is the Z wifi just that bad?

I am playing with a simple python script to capture a LIFX Z current state before changing to another state and later returning to the previous values.

If I then apply those different settings I see between 0 and maybe 10 max zones change, this varies.
Basically sometimes it works and sometimes it doesn’t but it never works properly.

I am using the States method and as I am setting different colours per zone I have to send the settings for each zone separately, e.g. selector ID:bulbid|zonenumber essentially send the details for a standard bulb 15 times with the |zone number.

Has anyone else used the HTTP API and what results are they seeing ?

For me the Z units are pretty bad, dropping off the network every 24 to 48 hours and now not responding to HTTP requests properly. - Edit - pretty much proved the problem is the wifi on the device, the HTTP API is unable to connect to the Z at times so use is patchy at best. My 7 original bulbs have no problems at all but the Z is well crap.

“results”: [
{
“operation”: {
“selector”: “id:d073d514f0a8|0”,
“power”: “on”,
“color”: “hue:271 saturation:1”,
“brightness”: 1,
“duration”: 10
},
“results”: [
{
“id”: “d073d514f0a8”,
“status”: “timed_out”,
“label”: “LIFX Z2”
}
]
},

The Z devices do have much, much more finnicky connections than the bulbs, which doesn’t really make sense, considering they have their own unique box with all the tech crammed into it, instead of being crammed under a bulb. It’s really a shame, because if you want LED strips and want them compatible with the LIFX ecosystem, that’s what you’re stuck with.

As far as connectivity is concerned, make sure you have full signal on your Z strips (dive into the bulb/strip in the app and hit “Edit”) - this should show 4 filled circles. If it’s 3 out of 4 filled circles, I can guarantee you that you’re going to lose a connection. If you do have full signal, I would assign the strip a static IP address. If not, you might want to look into moving the controller (the little intermediary box between the plug and the lights) to somewhere more visible, or possibly move your router closer.

As far as assignment via HTTP API, I haven’t tried it out (yet) with the Z strips, but it sounds like you do need to send a message to each zone. If you think about it, how else is it going to work? However, it might be possible to send the values for each segment as a JSON array (though I’m not positive). You could try it out at least, or contact LIFX directly for some answers. For assigning a single color, from what I hear, you just send a message to the entire strip like you would a bulb - you don’t need to send 16 different messages for the same colors.

1 Like

Thanks, yes I realise how the strips work and we have to treat the zones like bulbs in states if you want to control them individually or send to the bulb in general to set all zones, my settings all worked but the HTTP api failed to set the zones properly most of the time and not at all at sometimes.

My strips have 4 of those dots so full signal, one lasts a day or two the other now is lucky to last 20 mins.

If I use the LAN api I can poll the lights every 15 seconds and watch as the strips just stop responding to all but their presence and then details start failing (product, groups etc) and shortly after they are no longer on the network, power off for a while and they are back online again properly responding.
It appears as if the wifi chip is crashing which was noted a while ago re the Atheros chip.

Simply put the strips are a failure, I would not suggest purchasing them to anyone but if you do be prepared to probably send it back.

Contact LIFX support. They replaced one of mine with similar conditions and
it hasn’t crashed or gone off the network but a couple times.

  • doug

They already have replaced one and the new one does exactly the same.
Am contacting them again but not impressed unless I got an old problem unit as a replacement.

I was told by the tech that an RMA was needed and he would test it before sending out, he didn’t it was new but possibly an old unit, not sure.

Thanks for letting me know your experience, maybe there might be a resolution to this.