LIFX Developer Zone

Lifx Z Strip Will not update

This is my third Z strip. I cannot get it to update. The app just sits on discovering and nothing else happens. I have tried resetting my network, the light, and reinstalling the lifx app on my phone. Am I missing something here?

HI this sounds really quite odd. Could you log a ticket on support.lifx.com as they might be able to help with it.

This is also happening to me with my LIFX Zs or if I choose “firmware update” in the app for all bulbs. Tried submitting a ticket weeks ago, no response.

Actually this may be related to the DHCP bug noted in another thread. I could not get the strip to obtain an IP without installing another DHCP server. Cisco was not supported not was UniFi. ISC DHCP did do the trick. That being said, I also notice the strips fall off the network for no reason requiring an power cycle. My guess is that this is also related to the DHCP implementation. I have not wiresharked/sniffed the DHCP traffic yet to validate, but smells like the same issue to me.

Were you able to resolve your issue by getting in contact with support?

No, support never responded. That being said, I haven’t tried updating them
since.

You could always try contacting support again. They’ve been very responsive with me. It might’ve been that your message got lost somewhere because of a ticketing system update or someone who was assigned the ticket but was let go. Always worth trying again, but it might be better to do the firmware update first.

Update:
I dusted off and was able to update all 3 of my Z strip controllers
today. It only took me 4 hours and fists full of hair to get them
re-connected afterwards. I reset the controllers like 15 times, my router
like 15 times, power cycled the strips, and finally, one by one, was able
to get them re-connected. I wish I could share exactly what the magic
combination was that allowed it to work but there seemed to be no rhyme or
reason. Worth noting was the observation made with all 3 strip controllers;
Everything seemed to work fine up until the point where the app was trying
to find the strip controller on the network and timed out. I verified that
the controller was in fact showing up as connected on the router (eero) and
it would still time out over and over again. After about 20-30 attempts and
re-setting and power-cycling everything, it worked for no known reason.
This was the same experience for EACH individual controller.
I love the LIFX line of products and when they work they are awesome!
But basic functionality of the product should take precedence over
EVERYTHING ELSE! I’m scared to death when I have to update the 17 LIFX +
bulbs in the overhang around the perimeter of my house. Last time I did I
had to do a factory reset to ALL of them to regain connectivity with a few
of them (because I can’t reach them without hiring someone with a 30’
ladder). It took me ALL DAY to get them re-connected. Perhaps next time
I’ll delve a little deeper with wireshark and see if there is anything more
revealing.
Also, I don’t know if I’m on an ignore list for tech support or what.
I used to get answers back from them and then all of the sudden, nothing.
I’ve had a LIFX + bulb fail completely (does absolutely nothing) and tried
to reach out for a replacement with absolutely no response. So, c’mon LIFX.
I’ve bought like $3,500 worth of your products. the least you could do is
answer me back.

Solution-- I was able to update my LIFX Z strips with the desktop updater: https://www.lifx.com/pages/updates

Download according to your computer’s OS and run. My strips were unable to update using the app for my android phone; stuck in either “inactive” or “discovering”. The Gen 2 desktop updater updated every bulb on the wifi network in around 20-secs each.

PC should be on the WIFI, not ethernet for the updater to work.