LIFX Developer Zone

LIFX Z won’t work, even with Amazon Eero

DISCLAIMER: I have already started a support ticket, but as you’ll read in this post nothing has changed so far, so I am searching support from the community.
System: iOS

Hello everyone,
I bought my first LIFX product on February 3th, 2020 on Amazon Italy. After some troubleshooting, I was able to set up with my network. It worked pretty flawlessly for 3 weeks, then it got disconnected. Since then I tried every method I found on internet: hardware reset, renaming the network, opening TCP and UDP ports, setting a bandwidth limit, nothing has worked so far.

Then I have recently opened a support ticket, they made me do a network scan and I told them that I was willing to buy an Amazon Eero (base model, as I live in a small apartment and I don’t have any type of Internet problems).
I set it up, I opened the ports for my LIFX Z STRIP, and then, guess what: NOTHING HAS CHANGED. At the first attempt I was able to reach the ‘scan HomeKit code’ but then the app got freezed and every time I tried to set it up (via ‘Setup new device’ , via ‘LIFX WiFi method’ with the Home or the LIFX app, I ALSO TRIED WITH ANDROID!!) the strip in the best case would have got connected to the network for a second, then it got immediately disconnected. I am so done with this. I got plenty of Hue products, none of them caused me any problems. I bought the router that they marked as ‘perfectly compatible’, I followed their instructions, but NOTHING CHANGES. I spent more than €70 euros (+ the modem) for a product THAT DOESN’T WORK AS CLAIMED. This is simply unacceptable.

I need your help. I am getting kinda crazy, it is becoming an obsession for me.

NOTE: I am a Computer Science student at Politechnic of Milan, imagine being a dude without any type of skills in this field. Is this a beta product, or does it pretend to be a real, world-wide sellable product?