LIFX Developer Zone

Mini color setup on iOS without HomeKit impossible?

I’ve been working at this for over 2 hours and I am incredibly frustrated.

I received a Mini Color in the mail today, plugged it in, turned it on, and opened up the app. I already have a bulb set up from over a year ago that works fine.

When I try to setup the bulb, the first ask is to set it up using HomeKit… I skip that because I’ve never used HomeKit and I don’t want to start now (I’ve got everything integrated with Alexa).

I now need to connect to the bulb’s WiFi network, which I attempt to do, but iOS prevents the connection because there’s “No Internet Connection” so I’m stuck not being able to connect to the bulb over WiFi.

I’ve tried the HomeKit setup, but it only works when I’m directly connected to the bulb’s WiFi network. If I’m connected to my home WiFi, the setup can’t find the bulb with the QR code.

I’ve gone as far as to download the BlueStacks Android emulator and attempt a setup on there, but I cannot “claim” the bulb from the app on the emulator.

Is there any way to solve this? I’m thinking of just returning the bulb and trying a different brand, this has been an absolute disaster.

edit: Did the new version of the app just launch? I’m wondering if that has something to do with all the issues I’m having.

edit2: I put my phone into airplane mode while connecting to the bulb’s wifi network and was able to at least get to the WiFi network selection menu but now I get an error that says “An issue has occurred while pairing your light to the Wi-Fi. Let’s reset and try again.”

edit3: I’ve tried everything in this post, and nothing has worked I Just Cannot Connect My Bulb Whatsoever

edit4: Jesus christ on a cracker I got it working. Here are the steps that I took:

  • Turn airplane mode on w/ WiFi on and connected to the bulb’s WiFi network
  • Ensure “Auto-Join” is selected for the bulb’s network
  • Ensure “Auto-Join” is de-selected for any other network nearby
  • Set up the bulb via the WiFi network, once the bulb is connected to your home’s WiFi network, re-connect back to your home network on your phone to finish the setup
  • The claim failed for me the first time, so I quit the app, and the bulb was waiting for me to finish the setup, where I was able to name it and claim it

3.5 hours and an insane amount of frustration. Cheers

2 Likes

There is a simpler way: turn the bulb on and go into the wifi settings in iOS. Wait for the bulb to appear under “Configure new device” on that screen. Tap the bulb and follow the prompts. When you’re done, go into the LIFX app and it’ll be waiting for you to finish the configuration.

The option to “Configure new device” never appeared, it only showed up in the normal list of WiFi networks.

That happens after 5 minutes of the bulb being on. The MFi discover option is only active for 5 minutes, AFAIK. If you want it to become MFi discoverable again, just turn it off for 20-30 seconds and back on again.

Just wanted to reply and THANK YOU for the instructions to fix! I was having issues connecting my light to my WIFI network… then turning on airplane mode, connecting to the light WIFI, opening the Lifx app, and proceeding that way you described, it totally worked for me.

I was about to return the product! Seems like the airplane mode was the trick. Also seems like the new App update is causing issues. Anyway, thanks again @alxmrtn

1 Like

@alxmrtn THANKS! I originally bought some “regular” LIFX bulbs and they were fairly easy to setup. Then I got this LIFX Mini and could not get it to work until I found your instructions. Setting this light up was WAY TOO difficult. You would think someone at LIFX would test a Mini with an iPhone without HomeKit! Like you said, my bulb never showed up in the “Configure new device” section, but your procedure worked.

1 Like