My IFTTT stopped working. Brightness always 0

I have used the same IFTTT applet since 2017 and it has worked fine. But recently it stopped working.

The effect since a week back (or so) is that not only will the color change, but the brightness will be set to 0 and not 50% as in the configuration. I have tried to change it to 60, 80, Do not change, but it makes no difference.
I also tried to use the “Advanced option”, but with the same result.
Any ideas?
I did not change anything when it stopped working. I have several IFTTT applets and they all experience the same problem.
My bulb is only of the original LIFX bulbs. It works perfectly well from the phone app.


We’re in the process of improving the implementation of our ifttt integration and it seems we introduced a bug where it would turn off your lights when you say no to “Turn on first”.

I have made the color applet use the old implementation for now and we’ll get to fixing the bug when we’re back at work after the weekend.

Do tell me if it’s still broken.

Well, that explains a lot! I have about 50 IFTTT → LIFX applets configured that stopped working about a week ago. I have several friends using IFTTT to control their LIFX lights and we all woke up in the dark on the same day this week :sweat_smile:

I was able to debug the problem and it seems that the IFTTT’s advanced field does not accept anymore exact color temperature settings (e.g. color:kelvin:2500). This is crucial for all of my applets (and my friends’ too) because we need to pass the color temperature as a variable to IFTTT. Please, dont’t tell me that you are going to abandon this extremely useful feature :pleading_face:

Hi Elenkhos,

We will not be abandoning this feature. We will ensure the old behaviour is maintained. Please keep us informed if there are any other behaviours that are not working as intended.

1 Like

Hi ThomasO and Elenkhos,

We have rolled back to our old integration and will fix the bugs in our new integration. Thank you for notifying us of the problem.

1 Like

It is working again now. Thank you for you quick response.

/Thomas O