New app doesn't work on iPhone 5s running iOS 9

Gets stuck at first screen

@Eric182 swiping to the left does not work?

Looking into providing a fix asap

That is correct. Swiping to the left doesn’t work. It’s frozen.

Same here, after latest update (3.7.0) on IOS10 with iPhone 6s and 7. App crashes or is stuck at first screen. Was working fine before.

Same here. Version 3.7.0 installed today, app freezes on the same screen as in the pic above, and all you can do is close the app. iPhone SE iOS 10.2.1. Has worked fine before.

Same here on iPhone 5s iOS 10.2.1

Same here, same screen, iPhone 6, iOS 10.2.1. Update, new app works flawlessly on my son’s 6S

@TomD @MaaadMikE @tajunta @shpokas1 @Eric182
A new version of the app should be available shortly on the app store.
Please let us know if that solves the issue for you.

1 Like

thank you. Appreciate the help.

Thanks. that update did the trick. Enjoying the new UI. thanks

1 Like

Update fixed it for me as well. Thank you!

1 Like

The update fixed the problem, thank you.

1 Like

fixed 20 characters s

1 Like