New LIFX with IR help

I have been testing these new bulbs in an enclosed fitting and noticed even during the day with the bulbs off in the LIFX App for IOS, the Eye icon remains lit indicating IR is on. I am wondering if the lamp fitting is creating a dark environment for the bulb’s brightness detection sensor and so it thinks its permanently dark.
My expectation was that if you turn the bulb off in the App, it turns it completely off, including the IR function. Can someone confirm the behaviour I am seeing?

The bulb does not try and work out when it is dark or not. Once an IR level is set the IR LEDs will light up whenever the visible light channels go under a self determined threshold. This threshold is controlled by the bulb and looks at heat and power consumption of that bulb

Ok, so based on that, why is my Vivotek IP camera showing an IR source from the bulb even though the bulb is in the OFF state in the IOS App?

The IR Leds, and hence the Eye icon, does not light up if the bulb is ON and above 8% brightness. Lowering the brightness to 5% turns on the IR and the Eye icon. The explanation given in the App when you select the Eye icon is:

“To enhance vision of your security camera, invisible infrared illumination (100%) will turn on automatically when brightness is low”.

I was interpreting this statement as meaning there was some sort of light sensor built in to the bulb to detect surrounding brightness levels…

Ok, so based on that, why is my Vivotek IP camera showing an IR source from the bulb even though the bulb is in the OFF state in the IOS App?

Turning a bulb off will not change the IR levels that the bulb has been set to produce. This is something that currently requires two operations to control.

The bulb will turn off the IR LEDs if the visible light channels increase when the combined power levels are over the power consumption limits of the bulb.

“To enhance vision of your security camera, invisible infrared illumination (100%) will turn on automatically when brightness is low”.

I’m going to check with the app team on this but I think this is just an ambiguously worded sentence.

Thanks Kevin, I am struggling to understand the explanation but get the idea. My issue then really comes down to the fact that the IR is constantly on, even during the day.
My only resolution to this is to use a Belkin Wemo light switch and set a schedule to kill power to the bulbs during the day.

Alternatively our http api is fairly easy to use. A curl or something similar in a timer would easily do what you want. https://api.developer.lifx.com/docs/set-state
iirc something like

curl -X PUT "https://api.lifx.com/v1/lights/all/state" \
   -H "Authorization: Bearer YOUR_APP_TOKEN" \
   -d "infrared=0"

Will turn off the infrared and this could just be a command run on a schedule. (This will work on a linux or os x box easily but require it to be on all the time. A windows box could also do this but you would probably want to use powershell and scheduler.)

I will talk to the others next week (it’s friday afternoon here.) and see if it is possible to set a schedule or ifttt to do this as well

Excellent. I’m in Oz, so think we are in the same timezone. When they were first announced I thought the obvious feature was to be able to schedule the IR in the same way you could schedule whites and colours. At the moment, we have no control over the IR as users.

Happy Friday :slight_smile:

We are working on firmware and code improvements all the time and certainly take feedback. I know there was some talk about schedules and IR but can’t recall it right now.

I can recommend the http api as a quick workaround.

Hope you have a great weekend.

Hi, new here and first post.

I got my LIFX+ bulbs yesterday and also can’t understand why the IR is on during the day consuming around 8.2W/bulb?! It is even better to set the bulb to a low 9% or red light as this will disable the IR LEDs and consume only 1.1W/bulb. Please LIFX give us an easy way to control the IR channel of the bulbs by a sunset/sunrise scheduler (inside the app, not IFTTT) of some kind as the http api is not ment for the normal user.

What’s the point having low energy bulbs classified A+ rating consuming 8.2W 24/24 7/7 if IR is not needed?

I have played with the HTTP API on the website to test and it works good. Am able to turn off the IR. Can you help me in getting that code into a file as I’m not familiar with scripting much. Do I copy/paste into a text file and save it as what extension?
I also tried adding it to a Stringify Flow using their Maker as its got the ability to specify a HTTP Put, but I can’t get it working. You need to specify the following in Maker:

URL = I put in https://api.lifx.com/v1/lights/group:My Group Name
Data = the choices are “No Data”, “Form Data”, “JSON data” and “File via Multipart formdata”

I selected Form Data and then had to fill in 2 fields they give you:
Field 1 Name = Power
Field 1 Value = Off
Field 2 Name = Infrared
Field 2 Value = 0

Finally, it asks for Authentication Type, between “Basic Auth” and “Bearer Token”. I chose Bearer Token and entered my Lifx Token.

didn’t work…

Any more advice Lifx?

I have put the http api data in my domotica system, a Zipato Zipatile, and that is working great for the moment. Using a virtual switch I can control the IR LEDs inside my bulbs.

Easiest way for me is to make things work with the “try it” function on LIFX http API website and then I copy-paste the values from the different fields into my application, Zipato rules, Flic button or IFTTT.

If you are a SmartThings user, I should have my Better LIFX Bulb device handler updated next week to control IR plus scheduling. My LIFX Z should be here tomorrow.

If you guys want to control the IR and have SmartThings, you can use my updated Device Handler. I haven’t spent a ton of time, but it works. I suggest using CoRE to schedule IR on/off using the irOn(level [0-1]) and irOff() methods. You can also custom set the IR level in the device settings for the default level for the IR to come on at when the bulb is off. If you plan on only using CoRE to set the IR on/off, just set the custom level to 0 and let CoRE do the rest.

@daniel_hall

Glad I wasn’t the only one noticing this.

It’s common sense that users would want to disable “night vision” as well, for example by tapping the “eye icon” to toggle IR light on/off. Also the ability to schedule it. In its current state it’s a total energy waster during the day.

Please fix this on a firmware update!

1 Like

Is there an easy way to deal with this yet? I don’t understand why IR is blazing in the daylight.

@JimSlimbo The ability to create schedules for IR brightness has been added to the latest iOS build (3.8.1) and will be added to the next Android release.

1 Like

Oh that’s great! I’ve had two floods blazing away since July and just added two A19s three weeks ago. Love the bulbs. The IR during the day thing has been on my list of things to find a way to fix so I’m very glad to hear that a solution is coming! Thanks for the quick reply.

Markh as per your there will be an ability to set the ir brightness in the next android update. I’m running 3.8.3 and have found this in the schedule as an option. However that means that i must run a schedule to have the ir off. Is there going to be a way to turn the ir on or off, permanently added to another update. A simple setting to have it on or off would be great.

@Blu if you go into the Settings of the LIFX+ light that you want to change (by clicking on the Cog icon when you are on the light’s control screen) there is a dropdown that allows you to set a persistent IR brightness.