LIFX Developer Zone

New update broke all my Lifx


#1

Got three Lifx Color 2nd gen. Was using the app then was asked to update with new firmware. It got an error while updating and now all my Lifx are offline. Tried hard reset power refresh 5 times but it won’t reset it. When I turned off and on the lights, it would blink bright and dim few times

What do I do now?


#2

This sounds like something where you should email LIFX Support.

Also, if you reset the lights, they may no longer be on your Wi-Fi, and you might wanna set them up again in the app. I don’t know the situation you’re talking about, but that might help you figure out what’s going on.


#3

I just ran the update on my 46 devices, 3 of them are now no longer working either. They are on, but they cannot be controlled via the app or integrations. I’ve tried powering them on/off but that doesn’t help. The lights just flash between two different whites. I tried factory resetting one of them, no luck, same behavior. They just flash between 2 different white colors. I’m submitting tickets.


#5

Sorry I just realized this is a developer’s forum not a LIFX user forum. My apologies


#6

I finally able to make them work again.
Whatever you do, Do Not delete them from your list of lights
Open the app and see if the firmware update message comes on then continue the update. It will fix the problem. I think there is a manual toggle as well to start the update at the individual bulb setting itself

If you had deleted one you have to put them in recovery mode using a desktop computer