LIFX Developer Zone

Painful installation

Why is it so painful to install those lamps, I recently purchased 11 Lifx bulbs and it took me almost an entire day to install them all, first the lamp wifi wasn’t strong enough to reach my phone so I had to literally stand below each lamp to have the signal, secondly there was the issues with the app, took forever to configure each lamp and sometime just crashed the app or just stays on the same screen for more than half hour, and when finally I get to the last step, when ask me to re-choose my regular wifi connection, the app didn’t find my network anymore. I had to put the phone on the airplane mode to at some how reset the wifi and get back to the app and then finish the process…

Why Lifx?.. Why?

1 Like

First what phone are you using ?
second their wifi is dodgy on the latest bulbs (staying connected) but is well and truly strong enough so being that close does not sound right.

If you are using Android and a recent version it is possible that Android was connecting to your lights wifi but as there is no internet connection the phone uses your mobile connection for data or just rejects the connection.
The LIFX app detects this and asks you to go to wifi and connect to it manually then you go back to the app and it adds the bulb.

I have 7 bulbs and 2 Z strips and never had these issues.

I disable cellular data when I add bulbs using my Nexus and it works really well.

I have 17 of the LIFX + bulbs that go under the outside soffit all of the way around my house. I had to hire a painting company with a 30’ ladder to install them all. Needless to say, when I have a problem with just one bulb, I am forced to reset ALL bulbs. Then I have to manually connect each bulb back onto my wifi network. Theoretically this should take about a half hour or so but ends up taking me ALL
DAY!!! The bulbs RARELY connect without a hitch and I sometimes have to try like 30 times just to get ONE BULB connected! I’ve tried airplane mode, turning bulbs on/off, standing under bulb with phone (Nexus 5), Standing on my head, ect. Connecting is VERY hit or miss (mostly miss). I notice when the app is trying to send wifi credentials to the bulb that the phone’s wifi keeps bouncing back and forth between my wifi AP and the bulb’s AP. This is frustrating beyond what I can put in words here. The product is great but the connecting part of the software is clunky and un-polished at best.
Also, Now the bulbs are all mixed in with my “downstairs” location and I can’t seem to get them back in my “outside” location no matter what I do.

1 Like

Ouch. I feel your pain. I am using Z lights at the moment and having no end of problems.

Have you done a firmware update on the bulbs yet ? If not install the updater https://www.lifx.com/pages/updates on a laptop or similar with wifi. The bulbs don’t need to be on the network to run. This works so much better than updating via phone. Ensure you have the latest firmware.

As I said if you are using Android and what you are saying seems to reflect that go into your mobile data and disable mobile data whilst you are configuring the bulbs. This helps a lot. I had real issues adding my Z units before I did the firmware update but once I did that they were much easier. (keeping them on the network is another issue)
I have also found that once I have manually connected to the bulbs setup wifi with mobile data turned off the phone remembers that and is much easier next time, that is the switching back and forth between wifi networks stops.

Check your router, make sure you are using only 2.4 ghz and not in the low or high channels and . If you can set a reserved IP address for each bulb and check that your router does not have too many devices connected to it

Having one bulb go down should not be an issue for any other bulbs, that is just weird.

You can easily change the group in the app by clicking on the settings icon in the bulb. if this is failing maybe firmware version ?

Raise a ticket with their support team. I hope you can get it all sorted out.

I assume you have seen these.


Once my bulbs are connected, everything seems fine. (It was the last firmware upgrade which caused the one bulb to be unresponsive.) I cannot access the 17 bulbs in my soffit as I don’t have a 30’ ladder which is what forced me to re-set ALL of the bulbs (just to reset the ONE bulb). Re-connecting all of them to my wifi was the pain (but once done, all seems fine (even Z strips)). I tried airplane mode (effectively disabling mobile data) but still hit or miss. I’ve had similar results trying to connect to a raspberry pi running Arch and HostAPD with an ALFA AWUS036NHA for an access point (strictly 2.4ghz) and again, hit or miss.
Interesting to note: Sometimes the app asks me to go into my wifi settings and manually connect to the bulb’s SSID and then back to the app to connect and this NEVER WORKS! Rarely, but sometimes, the bulb connects right away, first try!
As far as the app locations go, I was able to get what I wanted by creating a new group for each individual bulb in the location that I wanted them in. Once that was done I moved them all to the groups I wanted them in in that same location. Kinda hard to explain in words. A bug I assume.

1 Like

Same issue for me. Configured 6 LIFX gen 3 Color 1000’s and the setup process was failure after failure. (even when disabling mobile data) - Tried with other devices and same thing.

One more time…. it’s fuc@#$ annoying that a company like lifx keep developing new products while there is much room to improvement on the current ones.

I recently bought 11 lamps like I said before and one of them stopped working (I used to like so much lifx because they created the technology but I’m seriously thinking to switch to philips hue), and I dent back to amazon and they sent a new one. Same drama to install this new one. I have an iPhone 7 fully updated, had disabled the celular data by putting on airplane mode and then adding the WiFi. Same very narrow signal from the lamp and I had to stand below it, once the princess lamp decide to work, the next issue comes up. When the lamp is ready and configured, the app doesn’t see my regular network so the lamp could never connect to my network. Did everything, airplane mode, disable and enable the WiFi several times, quit the app another hundred of times. the link is to a picture of my phone with one of the errors.

If I wasn’t so lazy, I would go to amazon to write a bad review about you… it’d be helpful for other people that are not a tibetan monk like me and have the patience and commitment that the setup process requires.

2 Likes

Though out the years this process has become as easy as feeding a sick toddler food it doesn’t like while its having a temper tantrum.
Ive tried Iphone, android phones, airplane modes on/off and all guides I could find. Every time these lamps spontaneously loose their wifi communication settings my heart sinks.
Because I know, ill be spending the next couple of days, burning my fingers a billion times resetting the bulb over and over and over again. Since I am an early adopter, support it limited for my older generation bulbs.
At the moment 3 lights are in full dementia mode, so again the nightmare begins again. I got my android phone charged to see if I have more luck.

I do have to say that lifx made a very fragile and difficult setup tool. If only there was some kind of verbose mode so you could see at what point exactly the process fails. The lifx team doesnt seem that much bothered with the complaints about these setups since it hasnt changed of improved over the years. I think it actually got worse.