Persist setting on breathe and pulse effects having no effect

I’ve tried a few effects using the breathe and pulse http api, but the persist setting seems to make no difference - true or false leaves the bulbs at the last effect colour rather than reverting to the initial state ( “persist”: false ).

I’m sure it used to work as specified the documentation pages.

Hi cee_jay,

I know this doesn’t help you, but it works fine for me, persist false resets to initial setting.
But at least you know it must be something with your code and not an error with the API.

Here is my call that works (I am using JavaScript):
"POST"
https://api.lifx.com/v1/lights/label:Back/effects/pulse
{“color”:“green”, “from_color”:“red”,“period”:2.0,“cycles”:30,“persist”:false,“power_on”:true}

Thanks, but I’m sure it’s not (just) my code. I get the same result using the ‘try it’ examples on the documentation site, Stringify and IFTTT (when the latter bothers to do anything).

I’ve been trying this on and off over the lat few days and for me the persist setting has no effect - the lights retain their breathe/pulse colour at the end of the cycle whether persist is set to true or false.

I thought it may have just been my bulbs, but I have been contacted by another user on the Stringify forums who is having exactly the same problem. Why does this apparently work for some people and not others?

I am using Color 1000 with up-to-date firmware, so not sure what I can change there.

Hi there,

Developer from the Yonomi engineering team here. We’re also seeing this same behaviour and have a couple of users reporting the same issue through our support channels.

This appears to have been affected by a firmware change and I was just able to reproduce the issue after not seeing it on a LIFX Color 1000 bulb on firmware version 1.13, then updating the bulb to firmware version 1.20 and suddenly seeing it occur.

From what I understand and can see, the persist field is supposed to default to false, but in any case, the bulb always acts as if persist = true – regardless of whether the field is set to false, true, or whether it’s present in the payload at all – and leaves the bulb on the new color.

Breathe alerts seem to be different and seems to always leave the bulb in the original state, again, regardless of the persist value.

As far as I can tell this definitely seems to be a bug with the new firmware in some way.

Any advice?

Thanks

Thanks for confirming it’s not just me.

It’s interesting that ‘pulse’ now appears to be respecting the persist setting - it wasn’t when I tried 2-3 weeks ago.

I did wonder whether it was a firmware issue, but didn’t have a bulb on anything other than v1.20 to test.

To clarify – neither one of them seems to be respecting the requested persist value – Pulse & Breathe actions just appear to ignore it in different ways :slight_smile:

Me too! Same thing is happening to me!