LIFX Developer Zone

Setup WITHOUT HOMEKIT

I have two new LIFX bulbs (my first), and I’m trying to get them connected to my network.

However, while I own an iPhone, I do not want them connected to HomeKit. I’m already running HomeAssistant and have no interest in cloud-based home device management.

I can connect to the bulbs’ temporary wifi networks and I dismiss iOS’s “Add to Home and Wifi?” dialog, but when I return to the LIFX app, even though I selected “My Device Doesn’t Support HomeKit”, I can’t progress past the “123” menu (the right green arrow button is greyed out).

Where do I go to just enter the SSID and password to get these bulbs onto my network, without getting additional parties involved in that transaction?

Hello,

If you wait 15 minutes after turning them on, the App will give you a legacy onboarding option and you can onboard it without homekit using that :slight_smile:

UPDATE
I don’t know why, but the app wasn’t moving forward to the “Communicating with Device…” screen. Now it’s working perfectly!

yay, the system works! :slight_smile:

1 Like