LIFX Developer Zone

Siri + LIFX stops after 30-45 secs; Proof that modem is the problem

Problem
We used Siri with our 20 LIFX globes for 3 years without any trouble; however, we became annoyed that our original Technicolor TG-789 modem from iiNet was having Wi-Fi ‘brown-outs’. What is a Wi-Fi brown-out? The VDSL connection remains stable, Ethernet connected devices have Internet but Wi-Fi devices stop for 4secs-4mins, which results in YouTube and Netflix saying the connection is lost. It comes on automatically after it has sorted itself out.

So we bought a D-Link DSL-2888A modem in January this year and it never has Wi-Fi brown-outs so we fixed that problem. However, when Wi-Fi on the modem starts fresh, either because the modem has been restarted or the Wi-Fi is turned off and on in the settings page, then Siri can see and use the LIFX globes but only for 30-45 seconds. After then, the LIFX globes start to go offline for Siri, although the LIFX app can still see and use them. I tried countless times to reset globes and re-add them to the LIFX account, then reset them and add them to HomeKit first only to find they still disappear after 30-45 seconds.

After 6 months of using the new D-Link modem but not having Siri, we missed the Siri voice command functionality so I swapped the modem back to the TG-789 modem. Siri works perfectly again without fail day after day, although the modem still has Wi-Fi brown-outs. Again, Wi-Fi brown-outs do not occur with the new D-Link modem. So we either have brown-outs on the TG-789 or no Siri+LIFX on the D-Link modem. By the way, Siri works perfectly well on the D-Link modem on all our watches, phones and HomePods. Only the combination of Siri (all devices) + LIFX is the problem.

It turned out that the only difference between Siri+LIFX working and not working was the modem.

Investigation
To further investigate, I scoured through both modems’ settings pages and made a list of the settings. I was wondering whether anyone here might be able to see a setting that would cause the D-Link modem to prevent Siri and LIFX from working together after 30-45 seconds. The very odd thing is, as I’ve mentioned, within the first 30-45 seconds, Siri and LIFX get along perfectly well and can control everything by voice. What would make Siri think everything has gone offline afte 30-45 seconds? This only happens consistently with the D-Link modem. The Technicolor model does not have this problem and even after 6 months, its reconnection works with Siri and LIFX again without fail.

Question
Does anyone have any idea what would make the D-Link modem work for Siri+LIFX for 30-45 seconds and then for Siri to see LIFX globes go offline, even though the LIFX app can still control the LIFX globes? Is there a specific modem setting that anyone knows of? Appreciate any help!

Supporting files/visuals
Links to two files will help understand the setup:

  1. Modem settings comparison (XLSX) with two worksheets
  2. Home setup (PPTX)

Funny thing thou… Siri on your iPhone uses 5g and lifx use 2.4

I’d check you 2.4 setting on the new router

Some where in your router or logs or there mean you should be actually checking to see if the lifx bulb are off line.

You say that the app still works? Then the lifx are still on-line.

I’m assuming you mean home kit is off line. So your issue is with home kit.

Are any of the devices on a guest account?

I could see your settings or load them.

Make sure you set the 2.4 network to 20 MHz band with only. And there are a few other wifi setting you should check.

Have you tried a google assistant or amazon Alexa?

This sounds like something the support team can help with.

In the meantime, I’ve been given two suggestions:

  • Turn off airtime fairness
  • Set minimal multicast bitrate to 24Mbits

Yes, the bulbs all remain online and the LIFX app can still control them.

HomeKit is online, too, as far as I know but happy to hear what tests I could run to check. For me, it seems like a Siri/HomeKit+LIFX combined problem. Siri can access information from the Internet, such as asking for the current weather conditions an all our Apple devices. Also, can’t HomeKit work on the LAN without Internet access so our iPhones should surely be able to control the HomeKit-enabled LIFX globes on the LAN directly? I’ve read that this is how HomeKit controls devices faster than Google Home and Alexa, as HomeKit can access local devices without the need to go via the Internet.

Nothing is on a guest account. I disable all guest accounts.

The 2.4GHz settings on both modems are set to 20MHz channel width. I provided a view of all the settings from both modems in the supporting spreadsheet at the bottom of my original post. If you click on 'Modem settings comparison (XLSX) with two worksheets", you’ll see the second worksheet/tab details all of the settings side-by-side.

If there are more settings for the 2.4GHz band that may resolve Siri + LIFX having a longer communication span than 30-45 seconds, I’d love to know which ones they are. Any suggestions?

Yes, we’ve tried the Google Home app on our iPhones and it can continue to control the LIFX globes just like the LIFX app. The problem seems to be a HomeKit+LIFX combined issue, as far as I can tell.

The odd thing is that this issue only occurs with the D-Link modem and is consistent in behaviour. The Technicolor modem has no issue at all. Swapping the modem is the only thing that triggers the issue… and even then, everything works for 30-45 seconds and then it starts failing.

Yes, our Apple devices use 5GHz. However, I have changed my iPhone to the 2.4GHz band for testing purposes for hours at a time yet the issue remains.

Thanks for the suggestions, Stephen:

  • Turn off airtime fairness
    QOS is enabled on the Technicolor modem (which works) but the only QOS settings on the D-Link relate to Internet (WAN) rather than W-Fi

  • Set minimal multicast bitrate to 24Mbits
    I don’t see any multicast bitrate, IGMP or snoop setting in the D-Link modem… could this be called anything else?

I did put in a support request (#489144) for information earlier and was told that I’ve been registered for the early release of the next round of firmware. However, that doesn’t really tell me if this will be fixed and that’s essentially because we can’t figure out the root cause of the problem. That’s why I thought I’d ask the community. I’m a bit lost as to how to resolve this issue.

You said, can’t HomeKit work on the LAN without Internet access

I don’t think so I think it still talks to the Apple server

Darrin J. Calcutt

Thanks for the suggestions there I couldn’t remember all the settings, that I used on my ASUS Router

Right. Yeah, We apparently don’t have much knowledge about that particular router :frowning:

@delfick I can set a minimal data rate for the devices connected to my LIFX SSID, but I’m not sure I can limit just the multicast rate. Do support know if this configuration is possible on Unifi APs?

I’m not entirely sure, but after consulting with someone who knows more than me, this might help https://help.ui.com/hc/en-us/articles/115011813968-UniFi-airTime-What-s-Eating-your-Wi-Fi-Performance-

Thanks. Sadly I don’t have any of the AP models that supprt airTime.

1 Like