LIFX Developer Zone

Still cant connect my bulbs to Wi-Fi

The same thing is happening to me. I get the failed to onboard message. U am using 2.4GHz verizon fios network, with the channel set to auto. These worked fine back on my old comcast network, but cannot connect now that we have verizon. Please help!

Encryption should be AES only I believe. Search for info on LIFX reccomended settings for your wifi network but it sounds like TKIP may be your issue.

I forgot make sure you are not set to N only as well. WPA2 personal with AES should be good.

hey boxhead

no solution for this issue.
your recommendations brought no results :confused:

Regards!

Well that sucks. Has to be something going on. You said they connected with an open wifi network then when you out back security they didn’t. It says the problem is your security it seems.
As always contact LIFX support. This is a developers site so we are just trying to help and can do no more.

One last thing… you did factory reset the bulbs and then from a PC (mac or win) with WIFI run the updater ?
Sorry if you know this already but the factory reset bulb sends out its own temporary wifi SSID and the updater uses that to connect to the bulb. If you have not updated your firmware then joining bulbs is sometimes painful.

Good luck

Based on what Sawtaytoes said above, I was able to setup a new light using 2 devices.

I had one device connect to the light’s wifi and on the Lifx app sent my router’s wifi credentials and waited for it to say “Looking for light on network”. Then on the second device (connected to my regular wifi), I opened the Lifx app and selected the + button and selected “Connect light”. It said searching for new lights and eventually it listed the light I was trying to set up on the first device. I selected the light and retried sending the wifi credentials and it worked. The first device then also reported that it found the light on the network and then prompted the firmware update.

2 Likes

I’m really happy to see you got it working :smile:.

I think this problem will go away after the firmware update. Of the 14 bulbs I setup last week, none of them had the issue.

I moved to Google Wifi on the weekend and all my bulbs connected instantly and are more reliable than ever.

Mate you are an unsung hero. Been trying to fix this for like 4 hours already and it finally worked for me. All i did was connect the light to my computer and everything worked.

1 Like

Spent weeks with varying connection problems until eventually all 3 bulbs could not connect to Virgin Superhub. Took one bulb over to mum’s house and tested with her BT router. It took literally 90 seconds to set up, solid connection for hours. Went straight down to Currys PC World and bought netgear R7000 router only. Got home put cable router/modem into modem only mode, plugged in Netgear wifi router and haven’t had one problem since. Oh, and my house now has the best wifi both 2.4 and 5 it’s ever had. Blistering performance.

1 Like

I was having issues with the android app searching for bulb on network kept loooing back try taking your password of your router or add one too it mine didn’t have one and I added a password and instantly started working

I was having some issues with my Verizon fios router I also have an asus router which the lights connect too with no issues but its in the back of the apartment so couple of Lights had problem with staying connected. After reading alot of the post here and trying some of things I was able to get the Lifx to work on the fios router. Seems to be good and reliable so far. Happy probably saved me from getting one of those mesh systems for $300 or more.

I struggled with connecting (4) new bulbs today. I started by getting the PC firmware upgrade program and connecting to each of the 4 default bulb SSIDs and confirming that they were at the latest firmware revision. They were up to date from the store, no update required. I then attempted to connect them to my access point… WPA2 AES. I use a 64 character alphanumeric (hex) wifi key that I use with 15+ devices. LIFX bulbs do not like a long passkey… I would program the passphrase, the light would flash, I could see a connection attempt at the wireless access point, but never connected, and no IP was handed out from the DHCP server. I tried again with a 16 character passphrase, no other setting changes, and magically they all worked.

Generally, the iphone and ipad apps are tantamount to useless in diagnosing the problem, and they only lead to frustration. I really don’t understand why the developers can’t make a simple PC program which can provide better visibility into what’s going on during the onboarding process so that issues can be identified, logged, and diagnosed in a sensible way.

Kudos to the guy who wrote this… https://github.com/tserong/lifx-hacks/blob/master/onboard.py . This saved me hours of time and bullshit trying to diagnose through the app, having to type in passkeys on the iphone. I like the LIFX concept, but I’m disappointed in the initial onboarding software support so far. 5 hours of my life I’d like back.

Long story short: Use a 16 character WPA2 passkey.

works:
24ED559FDF6FECEA - WORKS

doesn’t work: 24ED559FDF6FECEA5732E46C29298D5757774A250A699F5A0A9D823AFAB0DED0

I suspect that the LIFX implementation doesn’t honor the 64 character HEX passphrase option allowed by the standard.

2 Likes

I am still searching for the solution. There are too many postings here. I want the simple one by step by step. I am using Samsung s7 and Xfinity X1 Technicolor XB3 Model DPC3941T. I tried different methods such as resetting, etc. Still unable to connect to WIFI.

I was trying to get two Series 1 bulbs connected. No matter what I tried - changing the wireless mode, channel, authentication, encryption - I couldn’t get the bulbs to connect to my network. Doesn’t help that the iOS app shows a generic error message with instructions on how to reset what I assume is a Series 2 or newer bulb.
I also tried using the macOS LIFX Firmware Updater with no luck.

Kudos to the guy who wrote this… https://github.com/tserong/lifx-hacks/blob/master/onboard.py . This saved me hours of time and bullshit trying to diagnose through the app, having to type in passkeys on the iphone.

The python script worked a treat! Within seconds the bulbs connected to the network and showed up in the iOS app ready for a firmware update!

1 Like

Agreed! lifx-hacks/onboard.py helped me setup a LIFX Original (firmware v2.1) when the iOS app (v3.15.1) failed to do so despite numerous attempts. Something is quite wrong when a script like that does a better job than the official app. Time for another round of QA? The wi-fi is provided by a Zyxel LTE3301 for what it’s worth.

@qerub @chemenski hey there, could you please explain to me how to do this? where do i need to put the script in? and where the ssid and password?

my problem is, that i cant connect one of my bulbs to the wifi. i tried every router config. tried to update the firmware via the mac osx app directly on to the bulb but it says “no device found…”
i have the 1gen lifx bulb

many thanks for your help

Open /Applications/Utilities/Terminal.app and enter (or paste) the following lines one by one, hitting the return key between each and replacing the placeholders with your values:

cd /tmp
curl -o lifx-onboard.py https://raw.githubusercontent.com/tserong/lifx-hacks/master/onboard.py
python lifx-onboard.py <ssid> <password>

thank you! but isn’t necessary to be connected to the lifx bulb via wlan? if so, I dont have any internet connection to load the URL. so I downloaded the python script on my desktop, opened terminal on desktop path and wrote "python onboard.py <mywlan> <mywlanpassword>" but then it says “-bash: syntax error near unexpected token `<’” any ideas? sorry … I am obviously not a developer :smiley: thanks!

Run the command python onboard.py mywlan mywlanpassword (without < and >) instead; those characters were just used to denotate the placeholders (a common convention).

Does this work for onboarding tiles?