LIFX Developer Zone

[URGENT] LIFX Connection dropping

#10

Mine is 3 meters from the closest UnuFi AP Pro. on Auto power which typically means high.

#11

I have 3 LIFX Strips that are all within 2 meters of the nearest Unifi AP AC Lite.

1 is about 6 inches off the ground, 1 is 4 feet off the ground, 1 is 6 feet off the ground. They all drop off about once every 4-5 days (all on different days). I have 2 LIFX Gen3 bulbs right by them and they have worked without issue for months.

#12

I have one single unit and am experiencing the same problem.

Firmware update from the phone failed completely, using the update app on Windows immediate detection and upgrade no issue.

Every single night I have to power down the Z, wait and power up again and back online it goes. My 7 gen 1 bulbs all work perfectly.

I raised a support request and was sent this "I’d love to see where you’re reading that, as I have the exact opposite take from working in support. " I informed the support person they should look at these very pages as this is where my comment came from that seems most people have this issue.

Anyway understandable that problems occur, an RMA was issued and I believe another unit is on its way to me now. The support team could respond a little faster but things have vastly improved since they started, it was a really good process which is so nice to see.

If you are still having problems with the Z talk to support, they will probably replace your controller like they said mine will be after testing the replacement.

#13

Further to this I am testing in my office. The z connects just fine and is found no problem.
Using LIFXLAN in Python I can run the helloworld sample and it finds the Z and supplies all details.
Give it 20 mins and whilst I can still control the Z the helloworld script fails, the Z responds to a connection request but does not return all details so the scripts fails. Give it 5 more mins and the Z is no longer on the network. Power off for 30 seconds and this process repeats itself.

The product is faulty or their firmware needs urgent work, this happens on two units so would appear to be a product fault not a unit fault.

1 Like
#14

don’t buy LIFX Z.

my family purchased 80 * A19/BR30 Gen 3 bulbs and 20 *Z strips to replace 50 Philips hue bulbs because LIFX is much brighter and its color is more accurate.

My original ASUS RT-68U couldn’t provide enough coverage for my home, so I have tried 6 Google WiFi access points, the result is that Z drops all the time, A19 and BR30 become unstable after I installed around 60A19/BR30 and 5*Z strips.

and then I tried 3*Cisco 3802i, the result is A19/BR30 seldom drops with 68 installed, but never can get Z onboard.

in the end, I tried to use 3Google wifi APs plus 3Cisco 3802i & 2504 controller, I could get 55A19/BR30 onboard on cisco, and 10A19 & 5*Z strips onboard on google, but both A19/BR30 and Z drop randomly all the time.

I even uninstalled all A19/BR30, and tried google wifi, cisco 3802, asus, and all the combinations for only 5*Z strips, Z drops all the time.

my conclusion: Z is faulty, A19/BR30 are fine but don’t try more than 60 bulbs if you home is smaller than 2500 SQ FT. (this is my guess that LIFX bulbs are installed too crowded in my case and create interference.)

I created a case support, and the person asks me to provide how I configured my router. actually, I have hired cisco certificated expert to do site survey and install APs in my home!

well, support also asks me if I like to return bulbs. I wish I could, but I live overseas and all the boxes were gone.

2 Likes
#15

It might be a little too early to tell completely but I think I discovered something pretty major that might apply to some of you.

I’ve had a Ethernet over Power adapter that I installed to generate a distant WiFi hotspot. (LIFX lights weren’t using that hotspot) but I ended up unplugging it with the intention of relocating it and after it’s been off for a day or so, I am seeing exceptionally improved response times on LIFX lights as well is no offline issues.

Hopefully this helps some others.

[body is too similar to what I posted in another related thread so I’m adding this]
[body is too similar to what I posted in another related thread so I’m adding this]

#16

A new firmware is coming we are told on here so fingers crossed this resolves the situation.

#17

I tried the beta, can’t see any improvement, cisco controllers still shows errors as follows,

*Dot1x_NW_MsgTask_6: Jul 01 23:17:24.239: %DOT1X-3-INVALID_WPA_KEY_STATE: 1x_eapkey.c:2819 Received EAPOL-key message while in invalid state (4) - version 1, type 3, descriptor 2

it happens to A19/BR30 randomly, but happens to Z every few seconds, and I guess it is the reason A19/BR30 drops and Z can’t get onboard.

according to Cisco’s technical document, client driver causes this kind of errors and needs to be upgraded.

#18

See [URGENT] LIFX Connection dropping

1 Like
#19

My Z has not skipped a beat since the 1.22 firmware went in

#20

I had almost given up. My lights would loose the wifi connection within 24 hours. Changing channels reestablished the connection, but it would be gone again in a day. I think the problem was the wifi channel selection. When I switched from the regular 1,6, or 11 to channel 10, there has been no problems.

#21

Hi all

Is this still working well following the firmware update or have they reverted back to disconnecting?

#22

( Hi Aaron :wave: )

I have 21 bulbs and 3 z strips connected to two Unifi UAC-AP-Lite devices. All but the Z are pretty rock solid now, and the Z’s are hanging up a lot less than they used to.

I have SmartThings, so I put all the Z strips on SmartThings outlet controls. Now I can whack them from anywhere.

#23

Looks like I’m having the same problem :frowning:

Had a few problems with the initial connection, sorted that.

The lights then disconnected and haven’t been able to get them back online.

Tried resetting twice, no luck. Raised a support request.

I now have lights that I can switch on and off manually… joke :frowning:

#24

Same - had 10 lights installed last week (7 flood lights and 3 internal) within a day they some of the dropped off line. Did everything discussed to get them back , and within 5 mins they went off again, luckily my supplier took them back - said it happens all the time and he has stopped carrying the product. I installed 10 new Hues, and they work perfectly. its unfortunate as the LIFX lights are awesome- but the connectivity issues are hopeless and seem to have been around for years, not sure how they stay in business as there must be a lot of returns.

#25

It would be interesting to see what Wifi chip is in each of your Wifi Routers. I had an issue with an Asus Router that seemed to be an issue with the Radio. Since I switch to a Cisco Aironet 3602E I haven’t had 1 problem with my Lifx bulbs and its been up for several months. See this post: Found issue with Asus Router Firmware - AC5300

For my Z Strips it appears there may be a bug in the Firmware when connecting to cisco hardware. See my post here (especially the update at the bottom): Issue with Z Strip and Cisco Equipment

#26

I was having the same disconnecting problem with all of my Gen3 bulbs but not on Gen1 and 2.

I came across a couple of enlightening threads from Reddit and here in the community, one stating a broadcast from another host in the network causing the bulbs to disconnect and the other about putting the lights in another segment in the network.

The easier one for me is to segment the Lifx bulbs and other IoT devices on a different routed LAN segment. So far it has been rock solid for 2 days using all the same hardware.

For a while I thought it was the wifi and been fiddling with channels and everything that has been suggested to do with the wifi router but it is the same thing. I hesitated going to network segments as I wanted all IoT on the same LAN as some do not work with Cloud connection like the Sonos, AV receivers and Harmony.

Anyway I think having Lifx on another network segment is workable. I’m going to attempt to find the device that is broadcasting to make the Gen3 bulbs go offline.

J

1 Like
#27

I am using Gen 2 bulbs and had problems for months using my Google Onhub router before they were finally fixed with a firmware update (whatever was prior to 1.22)

I opened the app for the first time in a long time a week ago and saw there was a firmware update to 1.22 available. Foolishly, I ran the update and now the connection problems are back. Of my 4 bulbs, at least 1 disconnects (and does not reconnect) per 24 hours. Overnight last night, 3 of them dropped.

This is really disappointing. I’m kicking myself for updating the firmware for what had been a wonderful 4 or 5 months without any problems.

Is there any solution to this? Is this an issue being tracked? Is there a new beta I can try and see if it fixes things?

Thanks

1 Like
#28

I’d been experiencing the connectivity drop issue for a few weeks and tried the official setup steps with no success.
After reading around on the forums I saw a comment about other WiFi devices on the same network causing the disconnect/brick issue.

What I did was to name my 2,4 ghz WiFi to Lifx and connect the bulbs only to it whilst connecting every other wifi device to the 5 ghz (with another ssid) and checking the box “AP Isolation”
This seems to permanenty fix the issue (no disconnects so far!)

1 Like
#29

I’m in the same exact boat as you. Is there a way to revert the firmware or push lifx to fix it …again? My only work around I can think of right now is to put all 8 bulbs back on a separate bridged wifi connection (which I was doing for a while before they fixed the original onhub issue). I’m hoping this will get these 1.22 bulbs connected.