LIFX Developer Zone

[URGENT] LIFX Connection dropping

#42

My LIFX bulbs have been rock solid on my new all-Ubiquiti network. They don’t have a dedicated AP/SSID, but I do have an SSID for 2G and a different one for 5G. All of the 5G capable devices are only configured with that network too.

It’s been great.

#43

I too always had random bulbs dropping off the network. Had an Asus AC68P router downstairs and Netgear EX7000 Extender upstairs. I have 21 bulbs and a few would always just drop off no matter what I tried.

Finally gave the Netgear Orbi wifi mesh system a try. Almost 2 weeks in and not a dropped bulb yet!

#44

I posted on here in the past, i have about 30 bulbs - A19’s and Z strips.
I moved to an all new UBNT network to fix the issue, 5xAC PRO ap’s dedicated SSID, the works.
Its worked for months, and then suddenly a19’s started to drop of the network.
I cant get them back on.
I try to re-add them and they get on the network, but have 300+ms pings and about 60% packet loss. The app cant even see them as online.

Essentially… again, another screwed system.

#45

Edit: Angry post removed. I’ll tone it down a bit.

#46

Check your version of your AP. I am on 3.7.40.6115. Updates for firmware will destroy the stability of the bulbs.

#47

And then there’s someone like me with 19 bulbs and 2 Z strips without a single connection issue on my Orbi wifi setup. Because you’re having problems doesn’t mean the bulbs are garbage.

#48

These bulbs are great when they work, but infuriating when they don’t.

What I’m learning is:

  • Phillip’s Hue requires $50 extra for a bridge
  • LIFX requires $300+ extra for a Mesh Wifi System :frowning:

It seems like MESH is the only way to go if you’re getting 10+ LIFX bulbs (am I wrong?) . Currently I’m using 12 bulbs in a 650 sqft condo. I even tried split the bulbs up between two different wifi routers. I still get drop offs, they make me mad.

#49

Almost a workaround. This was driving me nuts so I spent all morning investigating my LAN traffic to figure out what was going on.

TL;DR: workaround is to set your router to reserve an IP address for each LIFX Z’s MAC address. Each router will have a different way to do this. I have an AirPort Extreme Router. For this particular router you can configure this via Airport Utility by going to edit->advanced->DHCP and NAT->Reservations and create new ones.

This worked for several more hours than it had in the past. However, by 8 hours later, one of the lights had disconnected again. And another one soon after. So the below information might help - but there is still something that makes the LIFX Zs disconnect after a while. AUUGGGGGGH.

You should be able to get the MAC address by looking at the list of wireless clients while the light is correctly connected. Or you can use a LAN sniffer (I used LanScan).

I don’t know if the bug is in the LIFX firmware or other devices, but in my case two of the LIFX lights and my ecobee thermostats were getting the same IP addresses at different times. If the LIFX had an IP, for example, of 10.0.1.25, my ecobee thermostat would later get that same IP address. Most WiFi devices are resilient to this will renegotiate a new IP address when this happens. The LIFX Z seemed to just disappear if there was any conflict and never ask for another one until rebooted.

That’s what I surmised from my investigation - it’s likely an oversimplification of what’s going on. But it led me to try reserving IP addresses for 5 of my strips, and they have been consistently accessible the rest of the day (of course this might all change, but so far so good).

My router is configured to DHCP and give out dynamic addresses from 10.0.1.2 to 10.0.1.200. I picked addresses outside of this range for the reservations (10.0.1.230-234).

Screenshot of one of the reservations attached.

#50

Ug, I was completely wrong. Now 4/5 of the lights are no longer connected.

#51

I have an A19 that drops regularly, I figured out that if I restart my phone, the bulb will be connected when my phone turns back on. I think the app freezes and everyone thinks it’s the lights. Definitely not a final solution but it should get your lights back connected. Hope this helps someone

#52

i have the problem with losing connection of the LIFX Stripe. It is worse tham i thougt.

So the LIFX is not usable.

If i re-plug the Stripe it will work for a short while (ca. 20min), after this the stripe is disconnected.

PEASE HELP!!

Boris

#53

Contact LIFX support. Check the firmware on it. it could have old hardware and you need a new controller box. As always if you want support contact them.

#54

I have an Older White 800 Bulb and this stays connected permanently regardless of router settings but My Lif Z Strips and Brand New Colour A60 drops out after about 12 hours. Switching power off and back on instantly restores the connection. I have set my router as per Lifx recommendations but the problem still persists.

Its seems Lifx have engineered a standby mode into the new bulbs for EU Energy Regulations. Its as though the new Lifx products go into a deep standby mode after a certain amount of time that then results in a disconnection from the Network.

Whatever it is it means these are not as advertised and not fit for purpose so Lifx needs to sort this out fast before they end up in a Legal Battle or on the BBC Watchdog Show!

Come on Lifx, step up to the plate!

#55

I was about to come and post my LIFX Z uptime stats (30+ days) but the power was cut to my place yesterday when my solar PV system was activated, so the LIFX Z is only at 17 hours uptime since then.

However, my LIFX Z, Tile and Beam products all stay online as long as my “normal” bulbs which are a range of Mini and GU10/Downlights. I also have a bunch of original Kickstarter Original 1000 bulbs too.

Since moving to a pure Ubiquiti-powered network with two UAP-AC-Pro APs, my bulbs never fall off the network and I have 30+.

1 Like
#56

Hi Again Guys

Quick Update. I changed the Lease Time on my Router from 1 day to its max, 1 week and guess what? The problematic bulbs have stayed connected after 24hrs +

Lifx, please investigate why your newer products do not recognise when they are not connected after a lease renewal! PLEASE!

Cheers

#57

Hi Again

Why are there no Lifx Agents responding on here?

The problem is definitely due to the Lifx products not regularly updating there network lease. It seems the only time they do this is when you switch off and back on which is not the only time the lease should be renewed/updated.

Please read the information on the website found at the below link. I think everybody that reads it will very quickly understand and agree that the problem is definitely down to the lease not updating regularly enough!

DHCP Lease Renewal (Lifx Problem)

I know this article talks about Windows Server but the principles of DHCP are the same whether it be a Server or a Router.