LIFX Developer Zone

When a bulb goes "offline" why doesn't it try again?


#1

This is, perhaps, more of a user question but perhaps developers would have a sense. I often find bulbs will go offline and I can understand Wi-Fi glitches. If I power cycle comes online again. If power cycling works why can’t the software in the bulb just retry periodically?


Light stopped working
#2

The bulbs will try to reconnect if wither the connection to the cloud or the connection to your wifi network is severed. Including rebooting if they think they have gotten into an unrecoverable state.

We are currently tracking down a bug that sometimes stops this from happening.


#3

Please keep me informed since my experience is a solid “give-up”.I’ve seen no cases where it retried and succeeded without a power cycle. Note that since the bulbs only allow me to specify one SSID I’ve had to rename multiple IP’s with the same SSID/password so I presume you bind to that pair rather than a particular MAC address.

If you’re looking into the code it’s worth considering using Wi-Fi direct from a nearby to extend the range but that’s a bigger rethink.


#4

You are correct, the bulb will connect based on SSID and security key only, the BSSID, Encryption type, channel and other settings can change and the bulb should still be able to connect to the network.


#5

I sent a feedback report as requested by support but it doesn’t seem to show any useful information other than the bulb is inaccessible. At this point I have bulbs which seem to fail permanently but maybe I haven’t tried hard enough. For now I’d be to have automatic reconnect work.


#6

Hi everyone. I recently bought 2 lifx 1000. And maybe unrelated but setting up with the nexus 6p I had one bulb that just wouldn’t link with the app. I had to use my girlfriends nexus 5x. Anyways that same bulb seems to drop offline randomly. Only after a power cycle it will relink with the app. My other bulb has been linked with my WiFi router for 3 days with no problem. I hardware reset the troubled bulb, and same thing I could not add the bulb with my Nexus 6P I used and old galaxy with success. Still getting random drops.


#7

Hey @Ineedlight,

Have you emailed support at support@lifx.com. If one light is working with your router, and the other doesn’t this might be a hardware issue.


#8

Same problem. 3 bulbs, two perfect but one basically bricked. It comes back online sometimes on its own. It always comes back after a power cycle. Goes offline after about 30 minutes. It loses proper state in the app and then commands no longer respond

A support case has been opened so I can get a replacement.


#9

I also have a bulb or two that go offline intermittently…maybe once every two days on average. Powering off then back on is the only way to reboot it. It is not even ping-able when this happens.

I should mention (like someone else earlier) that I have a two router home network. My second router is set up with DD-WRT as a wired “client bridge” to the main router. Same SSID, Security, etc. It is used strictly to expand my wireless coverage, and passes everything to the main router.

I would be surprised if this is a hardware issue as opposed to something which can be fixed in firmware somehow.


#10

I also have the exact same problem, after a few minutes, one of the bulbs goes offline and a power cycle is the only way to bring it back on.
EDIT: I don’t know if it’s a factor, but I have 13 bulbs on the same Wifi network.


#11

What model of bulbs are you using?


#12

All the bulbs are White800.


#13

If it’s always the same bulb that goes offline then I guess that one bulb has an issue and LIFX’s support will help you.

If that bulb is isolated compared to the other 12 it might be interesting to test it at the location of a working bulb to weed out any issue related to its environment.


#14

No it’s random, sometimes it’s one, sometimes it’s two, and it can be any of the 13. But I never get to control the 13 at the same time for more than a few minutes (after I did a power cycle on the unresponsive ones).


#15

Sounds awfully like the same WiFi bug that’s affecting me and which is present in all LIFX products but the Original 1000, try different WiFi channels.

The bug is a crash within the Qualcomm Atheros (QCA4002) chip upon which LIFX bulbs are built.


#16

I tried 3 different channels this morning and each time, some of the bulbs would randomly go unresponsive after a few minutes. I still have a few other channels to try, I’ll let you know if a miracle happens.

EDIT after 3 hours, seems like the miracle channel is the holy channel 2. All the bulbs are MOSTLY reachable, mostly because every now and then one bulb becomes unresponsive for a few minutes, the longest unresponsive time is currently 762 seconds. But it reconnects successfully after that so I guess this is the best I’m going to get for now.
PS: channel 6 was also fine, but disconnects were more frequent and the unresponsive time was often longer than 2000 seconds (though it did manage to successfully reconnect too).
PPS: Also I disabled the second 5GHz WIFI network.


#17

I’m glad you found a channel that gives you better results! I invite you to report the problem at support@lifx.com.

You should definitely leave your 5Ghz channel, you’re making it worse for yourself by disabling it. The bulbs only work in 2.4Ghz, under no-circumstances can they be affected by a 5Ghz channel.


#18

Oh ok, thank you, I didn’t know that! I’m gonna switch it back on.


#19

I wish they had a watchdog timer to reset the bulb after a crash.


#20

Hi All I had pretty much had the exact same problem.

My Lifx White 800 would keep going offline and I kept having to switch it on and off again at the power source, before it would go offline after about 5 minutes. I tried buying an extender, because I thought the range may be the problem, and that didn’t work.

So I contacted Lifx and they sent me over a new firmware update in a beta version, see link, and I also changed my DCHP Lease Time to 48hrs.

I’m not sure if it mattered about me changing the lease time but I have been using it for roughly 2 days without it going offline once, a F****in miracle - so much frustration. So I think the firmware update is the key and I hope this helps out others with this very lovely problem.

[Link Censored, PM @daniel_hall or ask the support team to get it]

PS I also have been using the Flic button with the bulb and now it works a charm