[Yet Another] Bulb Connection Issues story (With Fixes!)

To make things quick, here’s the problem and the run down of the solutions / checks I went through:

Problem: Timeouts after “Looking for light on network” with some Reconnecting Loops for good measure

Attempts made…

  • Wifi Connectivity Checklist 1
  • Wifi Connectivity Checklist 2
  • Resets… lots and lots of resets.
  • Removing Wireless password (from existing WPA-PSK AES)
  • Disabling AOSS & WPS Setup
  • Checking (again) for any isolation settings on the Router
  • Disabling mobile data on my device (android; and this significantly sped up the Loop of Doom… but it was still stuck in a loop)

The one thing I didn’t do was change the Wireless SSID name to remove the space / or try making it shorter. I have a hunch this may have been the case, as anyone who’s done some wifi fiddling can attest to. Instead, I went full Network Admin on the solution…

The thing that Worked

I created a Virtual Network Interface (similar to some routers’ Guest Networks). It was a pretty simple setup with DD-WRT; used a short, alphanumeric SSID with a similarly short password (but still WPA-PSK AES).

After this, it didn’t even loop and connected promptly. Hope this helps someone out there, and best of luck!

1 Like